PCSU1000 and Vista Update : Serial Number ERROR!

Hello Everybody,

I’m writing this topic because I’ve just solved a big problem with my PCSU100 :
After a Windows Vista Update in order to include FTDI drivers with
the OS, my PCSU1000 was no longer working. Everytime I launch PCLab I was granted an “Open_USB_Device_By_Serial_Number” Error or the software was telling me an another PCLab was running…

=> I’ve tried to uninstall and reinstall the software and PCSU1000 drivers :
my oscilloscope still don’t want to work.
=> I’ve installed the oscilloscope on a XP workstation, it’s the same

I noticed that when I plug my PCSU1000, there was a message
“Usb<->Serial Converter detected” instead of “PCSU1000 detected”

So, I guessed there was something wrong with the content of the FTDI
peripheral EEPROM which contains the Device Serial Number and name.

I’ve read this EEPROM by using MProg 3.0. This utility is supplied on the FTDI website and allows you to read and write a FTDI EEPROM.

Surprisingly, the EEPROM was reseted like a USB-serial converter,
with no Device ID and no Manufacturer ID.

So, !!! BEWARE OF FTDI DRIVER UPDATE OF VISTA !!! wich erases the
content of the EEPROM of your PCSU 1000 !!

To solve this problem, I was lucky because I own another PCSU1000
which works perfectly.
So I read the content of the EEPROM using MProg 3.0 (“read and parse”, device = FT232BM) on the working oscilloscope and I copied the content of this EEPROM to the EEPROM of the out of order PCSU1000.

When I tried to launch PCLab, the oscilloscope was working !!

But now, I’ve two oscilloscope withe the same serial number…

Hoping, this post will help other people…


PS : mail me if you want a screenshot of a working PCSU1000 under MProg

Thank you for sending this report of the problem with Vista’s automatic driver update behavior.
It seems to detect the FTDI chip automatically an erases its EEPROM and the chip has then only the factory settings.
You had to do a lot of research work to locate and identify the problem.
You got your PCSU1000 scope working by copying the EEPROM content from the other PCSU1000 !
For other Vista owners, who have only one PCSU1000, here the content of the pcsu1000.ept file if you have to use the MProg.exe to re-program the EEPROM:

[Basic Details] Device Type=4 VID PID Type=2 USB VID=10cf USB PID=1000 [USB Power Options] Bus Powered=1 Self Powered=0 Max Bus Power=490 [USB Serial Number Control] Prefix= Use Fixed Serial Number=1 Fixed Serial Number=YEL952TL [USB Remote WakeUp] Enable Remote WakeUp=0 [Windows Plug and Play] Enable Plug and Play=1 [USB String Descriptors] Manufacturer=Velleman Product=PCSU1000 [Programming Options] Only Program Blank Devices=0 [BM Device Specific Options] USB Version Number=1 Disable Serial Number=0 IO Pin Pull Down in Suspend=0 Enable Isoch IN Transfers=0 Enable Isoch OUT Transfers=0
The serial number is same in all the units. It is used to identify this chip from the PCSU1000 program.