PCSGU250 Won't Calibrate/No Ready Light

Hello, I am having issues setting up my PCSGU250 oscilloscope/function generator. I am running Windows 10.

Seeing the other posts on the forum, I have tried:

  1. uninstall/reinstall software (PcLab2000LT v. 1.14)
  2. uninstall/reinstall drivers (pcsgu250_winusbdrv2)
  3. Checked the power consumption of the PCSGU250 - it is 498 mA.
  4. tried using the previously posted PCSGU250.ini files and changed HwDialog from 1 to 0.
  5. tried using another computer - same issue, but I have not gone through all the steps on that computer, only a normal install and trying the software.

In this case, I now have the software not opening up in Demo mode, but it wants to calibrate and stays at 0% Calibration. The Ready Light does not turn on. I believe the scope is not fully set up, but I do not know how to check. Windows recognizes the scope as well.

Thanks for the help!

It seems that your PCSGU250 may be defective.
You can return it for inspection/repair to your local Velleman dealer or direct to:

Velleman Projects Tech. Dept.
Legen Heirweg 33
9890 Gavere

Well, yesterday I was able to get it set up on a Windows 7 computer following some instructions on your website. It works fine on that computer, but not on the Windows 10 computer I am trying to use now.

When I open up PcLab2000LT, it says that calibration is needed, I click okay, the USB disconnected sound happens, and then the window shows up with Calibration 0% complete. So it sounds to me like some sort of communication/USB issue.

This may indicate the PC is not capable supplying enough current from the USB port.

Have you tried a different USB cable?
On the Windows 10 machine are you using a USB 3.0 port?

Yes, I have tried two different USB cables.

It is a USB 3.0 port on the Windows 10 machine, but it is also a USB 3.0 port on the Windows 7 machine where it does work correctly.

I will try looking into how much current is being consumed on the Windows 7 machine.