PCSGU250 Hang during Calibration

I Purchased a PCSGU250 yesterday.
I then installed the software
I then installed the unit and installed the driver software.
I downloaded the latest driver software from your site.

When starting the software the software started by stating it will calibrate.
It started calibrating 10% and then 20%.
Then it stopped there and I waited a long time but nothing Happened.

Can somebody please assist.

Johan Prinsloo

If not yet done, please download and install the latest driver “Drivers for Windows Vista and Windows 7. (Can also be used for Windows XP)” from: velleman.eu/support/download … U250&type=
Download and install also the latest software Rev 1.12 from the same site.

Here you can download the detailed step-by-step instructions how to install the driver: box.com/s/vh9olqyx3idhhxn8ujwm

Before installing you have to uninstall the current driver.

Here are instructions how to update the driver if you do not remove the current driver first:

For more info about the driver versions please see: viewtopic.php?f=10&t=12360

Done all that. Still stop at 20% calibration


I have even tried a externat power usb hub on. STill no ready light or calibration

There may be hardware problem in the PCSGU250.
Can you try in other PC?

If not, you can try following procedure to check if the oscilloscope is working OK:

  • If you are running Windows Vista or newer PC, locate the file PCSGU250.ini (if exist) in the folder:
    In older PCs the file is located in the folder: C:\Documents and Settings<username>\Local Settings\Application Data\Velleman\PCSGU250

  • Delete the file PCSGU250.ini

  • Disconnect the USB cable.

  • Run the PcLab2000LT.

  • Let it go to demo mode.

  • Then close the software.

  • Now locate again the file PCSGU250.ini and open it in a text editor.

  • In the file locate the line: HWdialog=1

  • Change it to: HWdialog=0

  • Save the file

  • Connect the USB cable and run the PcLab2000LT

  • In the Options menu select Hardware setup and there select PCSGU250.

Now the oscilloscope starts without the calibration and you can test its operation.
Connect the function generator output to the oscilloscope input to test.

Thanks a stack. What I did is

  1. uninstall the program totally
  2. downloaded the software for the program from your site.
  3. Install the downloaded program.

EUREKA!!! It calibrated and is functional.

Johan Prinsloo

This was good news!
Thank you for the post.