PCLAB2000SE v3.1, DriverLINX problem

Problem with DriverLINX.

When trying to run PCLAB2000 it always responds with “Cannot open DriverLINX driver, Please run INSTALL_DRV.EXE to install driver” repeatedly.

  • Windows SP SP3, Dell computer, Parralel connected and working with other programmes.
  • Load any version of PCLAB2000 from v1.34 (which previously worked!) up to the current download v3.1. No success
  • Did complete removal (including manual removal of Registry bits) between each try. Problem is same
  • Checked boot set-up of port, “PS/2”, OK.
  • Checked System, Hardware, Device Manager, Ports (COM & LPT), LPT1, ‘working properly’
  • Each time installation of drivers is reported as ‘complete’. PC cold rebooted 1x, 2x etc,… Checked location of the two files dportio.dll and .sys are in correct locations (…\system32 and …\system32\drivers respectively as well as in the PCLAB directory).
  • Note: stopped the security programme (Kaspersky Internet Security 8.0) for all the above as that did flag up various issues and may haver interfered the 1st time I tried to load.
  • I am the Administrator. Double checked!!!

Any ideas?
(BTW this has worked on this computer a year or so ago when I last used and before a major clean)

Have you done this:
In regedit look under:

There should be a “DLPortIO” key (folder) in there.
Delete it, reboot and run the PCLab2000SE.

:smiley: Excellent, that easy???
Fixed, thanks for your speedy response.
(Sometime I’d like to know why/how… another day)

Sorry about the problems you had with the driver.

The root cause is unknown.
One reason may be the key “ImagePath” is corrupted and points to wrong location. There should be the path to DLPortIO.SYS.
If this is the case, the re-installing the driver does not fix the path and problem persists.
The only way seems to be to remove the whole DLPortIO key.

I’m running Win7 Pro 64bit.
PCLAB2000 cannot load driverlinx. I use an old PCS500 and PCG10 on LPT
Just removed the key in register, used privileges and so on without succes.

thanks in advance

Sorry to say - The driver DriverLINX is not digitally signed.
It doesn’t run on 64-bit operating systems.

Here found some information about the DriverLINX driver:

DriverLINX and DlPortIo.sys doesn’t run on any 64 bit Windows edition. Independently whether signed or not. So you may safely delete dlportio.sys; it’s a useless file on such a system.

However, the (my) current InpOut32.dll will run the sub-programs successfully, e.g. “rundll32 inpout32,CatchIo pcs500” will run the scope application.

tu-chemnitz.de/~heha/viewzip … 3/Release/

When you get an error message following this link, please edit URL line and replace “#” by “%23”! Otherwise, the browser interprets “#” as bookmark delimiter.

  • Don’t use inpoutx64.dll for your 64 bit Windows. It is for 64-bit programs only.
  • Don’t install globally by moving inpout32.dll to %windir%\System32 directory unless you are sure to be part of a 32-bit process. The right destination directory is %windir%\SysWOW64.
  • You need administrative privileges to “run” inpout32.dll successfully. The command line above is best placed into a shell link (e.g. start menu item) where you can set a checkmark that UAC prompting occurs in front of invoking rundll32, inpout32.dll, and pcs500.exe.


Hi Henni,

Sorry to hijack the thread but I have the same problem of getting PCs500 to run on windows 7 64-bit.

The link you’ve provided in this thread didn’t work. I found a link in an earlier thread which appears to be the inpout32 file which is required (that particular thread talked about having to rename it).

I don’t understand what a “shell” is so, in the Velleman folder withinin program_files(x86) I created a batch file with “rundll32 inpout32,catchlo pcs500” as a text string in it. When I run the batch file, I get a message saying “inpout32 is not a valid Windows 32 application”.

I’m not a programmer nor Windows expert so any suggestions as to how to make this work would be greatly appreciated!



Hi Dave,

i managed to get the right file at www-user.tu-chemnitz.de/~heha/hs/
But apparently my pcs500 fuse broke and i dont got a spare one :smiley:

Ill come back here, if I got any news!

The link is broken by forum software.

However, a direct download link works fine:
www-user.tu-chemnitz.de/~heha/vi … pout32.dll

If Windows refuses to load this DLL using rundll32, your download is possibly corrupted.


P.S.: shell = en.wikipedia.org/wiki/Unix_shell
Here: cmd (NT command-line interface). Or Windows Explorer with its Shell Links (.lnk). A batch file (.bat) is executed (in case of 64-bit Windows) by cmd.exe. Best for a GUI program like PCS500.exe would be creating a shell link - or changing the command line in the Start Menu entry, which IS already a shell link.

Hi Henni,

The link now works and I have replaced the inpout32.dll file.

It still doesn’t work when I run my batch file though - I get the message “there was a problem starting inpout32. inpout32 is not a valid Win32 application”.

My batch file is run from the PCLAB200SE folder and contains the text “rundll32 inpout32,catchlo pcs500”

Out of curiosity, I right clicked on inpout32.dll and looked at its properties. It says it is “blocked”. So I clicked “unblock” and “apply”. Then I tired my batch file again and I get the same message. Then, when I look at the properties of inpoutdll32.dll, it is “blocked” again.

The “blocked” thing might not be significant but I’d reall like to get this to work if possible.



A blocked DLL sounds like a misbehaving virus scanner. So I checked this file against VirusTotal, with no suspicious result:
virustotal.com/de/url/8894d … /analysis/
Blocking a file is no standard Windows behaviour (what version/ServicePack/Bitness/SafetySoftware?) so you are alone with your problem until you find a clue why someone blocks an innocent file.
You may invoke “rundll32 inpout32,Info” to get a small but useful debug screen, but this requires an unblocked inpout32.dll too. Note that you should run As Administrator in either case.
It looks like this screenshot:


Hi Henni,

Thanks for your help on this!

I have made a little progress - if I do “run as administrator” on my batch file I now get a different message. It says “there was a problem starting input32. The specified module could not be found”.

As a test, I renamed input32.dll to input32.old and re-ran the batch file and I get the exact same message. It is as if it isn’t “seeing” inpout32.dll.

I checked the properties of the inpout32.dll and it is again “blocked”. I have tried unblocking it and clicking “apply” but as soon as I check it’s properties it is blocked again! It is Windows 7 which is doing this - it says it is because it came from another computer and it might be a risk.

I tried disabling the real time security but it didn’t make any difference.

I guess I need to find out how to permanently “unblock” this file!


Update - I have unblocked input32.dll by copying it to a different directory (it was in program_files_(x86)\velleman\pclab2000se), unblocking it, and copying it back. It is now unblocked.

Still get the same message though :slight_smile:

As a test, I copied the whole of the velleman folder out of program_files_(x86) and put it in my root C:\ and tried to run it from there but still get the same message.

Could input32.dll be looking for some other module which I haven’t installed properly?



inpout32! Otherwise, the DLL cannot be found by rundll32.

As you may check using “Dependency Walker” (Microsoft tool), inpout32.dll doesn’t have unusual dependencies.

Possibly, try using a path, like “rundll32 .\inpout32,Info”.
(But I don’t need it because I didn’t install inpout32.dll globally.)
Remove old versions of inpout32.dll out of %windir%\system32, %windir%\SysWOW64, %windir%\Sysnative, and other directories in %PATH% search path. Probably you have a renamed inpoutx64.dll there; don’t use it, delete it.


P.S.: I could reproduce the error message “Not a valid Win32 executable” by doing the following steps:

  • Download inpoutx64.dll to System32 directory using a 32-bit browser (i.e. Firefox)
  • Renaming it to inpout32.dll
    Symptom: Some Windows component rejects to load 64-bit modules out of the SysWOW64 directory, i.e. watches that SysWOW64 only contains 32-bit executeables (and possibly vice-versa, SysNative only contains 64-bit executeables).
    The (wrong) inpout32.dll is loaded first by rundll32.exe, even if the inpout32.dll is (also) in the current directory. To force using current directory, use the Linux way of specifying it: “rundll32 ./inpout32.dll,Info” (.dll is required). Or “rundll32 .\inpout32,Info” (.dll can be omitted).

Hello :slight_smile:

I came across this thread after trying to revive my PCS500 scope on a computer running Win7 64-bit, of course getting trouble with the DLPORTIO dll.

First, it seems that TU Chemnitz has changed the paths to user web spaces slightly, so henni’s link was no longer working. However, I think I found the correct link to his fork of inpout32 here: https://www-user.tu-chemnitz.de/~heha/hsn/inpout32-hs.zip

After downloading it, copying inpout32.dll to the PCLab2000SE folder, and running the aforementioned command line directive, the PCS500 software starts with no error messages. However, it cannot get any response from the scope, asking me to check that the scope is powered on (which it is) and to check the parallel port address (which should be correctly set to 3BC).

Any hints?