PCGU1000 Doesn't work on Windows Vista

I have the PCG10 working on Windows 2000 Windows XP and Windows Vista. I have the PCGU1000 working on Windows XP. But I cannot get working PCGU1000 on Windows Vista. The Driver Installation was completed successfully. And a Com Port (Com 3) was created. Also the USB Controller was created successfully. But everytime at starting the software I get the message “No response from function generator. Disconnect and reconnect the USB Cable”. I have changed the working device on Windows XP with the failed device on Windows Vista and there is the same problem. It must be a software problem.

Have you tried to run the Pc_Lab2000se.exe file in WinXp compatibility mode? It may help.

I’m currently facing the same problem with my PCGU1000 on the Vista Home Basic OS. Have tested it on WinXP, Win98 and Windows Vista Home Premium (in XP Compatibility mode) and they all work fine.

Have tried everything that I’ve read on these forums but the ON/READY light never comes on despite running PCLABS in Admin mode, XP2 compatibility mode, changing ports of the PCGU1000 between COM1 to COM10. I’ve also installed, uninstalled and reinstalled the drivers and PCLABS2000SE in various sequences but I keep getting the “No Function Generator response. Check the power adaptor connection and restart this program.” message on this Vista Home Basic system. If I play around with the ports, I first get a message to unplug the USB and reconnect. When I restart PCLABS, I get the previous message again.

Has anyone else experienced this? Is there a solution or do I need to change the operating system?

No need to change operating system. PCGU1000 works under Vista 32 bit versions.
You have to return your PCGU1000 for checking.

I have tested my unit under Vista Home Premium Service Pack 1 (SP1) 32-bit version and it works. I understand that it also works under Vista Business. However, under Vista Home Basic SP1, it does not. I am wondering if the problem is isolated to this particular variant of Vista 32-bit. I still believe this is a software problem. Is the “LPT plug & play” checkbox supposed to be checked (since it’s supposed to be running in compatibility mode)?

Are you able to test this? Anyway, is there a reason why the PCGU1000 cannot run natively on Vista (i.e. not under XP compatibility mode)? Thanks.

The “LPT plug & play” checkbox is only for the printer port connected instruments (PCS500, PCG10 etc.).

Strange that the generator doesn’t run on Vista Home Basic.

I see. Yes I’m also not sure (it’s becoming more of a frustration now) why it doesn’t work. It’s a real headache and to make things worse, I need it for work. So I’m not sure if it’s really Vista Home Basic (Service Pack 1) or some other conflict occurring on my laptop.

So if someone from Velleman has successfully tested it to work with Vista Home Basic (SP1), then I cannot be sure that even getting buying another operating system will solve my problem.

Just to share this after several days of trial and error, I have found an odd way of getting it to work. But it involves having a PCSU1000 oscilloscope plugged into the system as well. It’s even more complex than what I’ve read in another post. Here it is:

  1. Plug in both PCSU1000 and PCGU1000 (with power supply in).
  2. Launch PCLabs2000SE to activate the oscilloscope, followed by the function generator (I don’t understand why both devices cannot be activated simultaneously). Anyway, this is followed by the usual error message “No Function Generator response. Check the power adapter connection and restart this program.”
  3. Close the function generator window and plug out the power adapter from the function generator and plug it in again. Do NOT close the Oscilloscope window or the next step does not work.
  4. Activate the function generator again via PCLabs2000SE and the function generator should turn on.

Points I noted:
a) The function generator will not turn if the oscilloscope is not present and activated. You have to go through the procedure above again if the “No function generator response” message ever appears again.
b) I also replaced the HDD in my laptop with a spare one an installed WinXP Home and the function generator could not be activated. I was advised to try disabling the Windows Firewall and tried the procedure above and it proved successful. But it was strange that when I tried to re-enable the firewall, the function generator “on/ready” light went on and off, after which it stopped responding again. I had to turn off the firewall and repeat steps 1-4 above in the case of my WinXP system.

I therefore seriously think there may be some software code somewhere that conflicts with my laptop. I find it especially strange that the firewall activation would trigger a response by the function generator. I wonder if there is a patch available that addresses this.

Anyone who’s been unable to make their function generator work can try the procedure above.

hi, i had same problem. i used latest pc-lab version and solved it by activating xp compatibility mode and run as administrator.

Most probably there is a hardware problem with the PCGU1000. You have to return it for checking.

Had same problem, same operating system. Returned my unit for a new one, same problem. Running under XP compatability. Vista shows it under com ports and reports it working normal. Any how I could not see two units doing the exact same thing! I was fortunate when I changed com port from 13 to 2 and replugged the USB cable it worked fine. Who knows if it will tomorrow? :smiling_imp:

Anyhow I feel its a software issue and for once NOT Vista! Comments??