Part of screen brighter than rest

Hello gamereric21,

Try to set the contrast to 20.

Normally, the display will be shown better at this contrast setting (at 20).

Go to SETTINGS => LCD CONTRAST=> set value to 20. in stead of 40.
To save this change you will need to choose the “STORE SETTINGS” entry in the settings menu.


Velleman Support

It actually fixed itself. The bright leds started spreading to other parts over the course of a few days :slight_smile: