P2599 wiper delay kits


I’ve recently purchased 2 K2599 kits, and built one myself, the other was built by a friend completely separately.

On both kits, when 12v power is applied, the LED activates and a relay clicks. Nothing further happens, however long I wait. The same happens on all 3 switch positions. Removing power makes the relay click again. We’ve tried both 12v battery chargers and a car battery and have the same result with both power supplies.

Have you any thoughts or suggestions? Thanks :slight_smile:

Kit #1:

And kit #2 (we removed the diode to check if fitting the other way round made it work):

Hello !

I’m sorry to say, but the soldering work looks very poor to me.


Well, while that may be true, it’s not especially helpful. Some of the less-than-perfect soldering could be due to our attempts at removing and re-soldering components, especially on the second board.

While the soldering may not be perfect, we’ve checked for continuity and all seems to be OK on all circuits.

It seems odd that both kits have exactly the same problem when you try using them…

Has anyone any suggestions of ways we can fault-check before I try to return the kits to the supplier? :frowning:

If you have an electronics shop close you could try swapping the 555 IC and see if that is where the fault is.