Oscilloscope VM205

I bought the scope and plugged it into my RPI 2 with Raspian Jessie, enableing SPI and can not get any life in the scope. I also tried with Wheezy. So I went to the store and got a new board, same result. Is it not configured for the RPI2? or…???

The manual explicitly mentions Raspberry Pi 1 on its front page, but the product details do not. I will verify compatibility with the designer of the VM205.

Thanks for looking in to it…

It seems that the VM205 is not compatible with the Raspberry Pi 2.
The issue will be fixed in an upcoming software update.

Ok Thanks for the feedback.
Looking forward to the new software. I guess there are no timeframe…

Just tested the new software (rev12) on my RPI2 and its running beatifully…
thanks for the update

Thank you for the reply.
The software will be soon released on the Velleman website.

It’s possible to adapt your shield for the RPI2 with using the follows cable

txrobotic.fr/adaptateur-40-2 … -pi-b.html


Thanks, looks like a good thing.
But the problem was not the connection, it fits on the RPI2 (just a little bit off). The problem was the software that didn’t work on the RPI2.
But with the cable it will be nicer.


With the cable, you must change the pins connexion of the shield because the both connexions (shield and rpi) are a female connexions. so change the female connexion of the shield in a mal connexion is better.
I worked this and it’s well. I can take take you a photo to see it.

Best regards

but I’ve been doing that for another project mysellf

hello to you I have a serious problem I just bought my VM205 and my raspberry b I would like to know how the program how to take what is the platform to develop my application of the oscilloscope and logic analyzer 10 ways