No response to Manual Controls

As per the manual,
Setup Repetier configuration
Connected and callibrated the motors for ~0.45V each.
Connected the USB cable, using the Repetier host, hit the connect button, indicator says connects successfully.
Printer board shows blink green light when powered and blink orange light when the USB is connected.

Problem 1:
I get the following line in the log:

Understand it should be firmware Marlin? and point to

Problem 2:
I tried the manual control for he various motors the software says ok, in the log file, however nothing moves in any of the motoros.

Problem 3: Tried heating the extruder (from 20 to 150C) and the build plate (from 20 to 50C), software says it is successful, but no change in temperature. Software heat graph shows success too in rising and falling.

Troubeshooting done so far;
Hit reset button on printer board after disconnecting software, USB cable and reconnected
Checked motors are mechanically free
Checked the motor connector cables for continuity (1/2 and 3/4 short)

Kindly help


Since I am a newbie, would appreciate pointers to:
I have done something wrong in the steps
Do I have a faulty board that I need to replace
Do I need to reset the firmware, if so how?

Thank you,

  • W

Hi w_sunil,

easily resolved: just switch to the correct connection profile in Repetier Host. RH has a default setting, which is a virtual printer for testing purposes. You probably have added a second connection profile (if not - do so!), which has the correct settings for your printer, i.e. the axes configuration, the COM port etc. You can select that profile for connection by clicking on the right side of the connect button (the small triangle).


Thanks Kuraasu for your continued support on this forum, it is really helpful.

Thank you Kuraasu. That was helpful.

Created a printer profile, however when I try to connect, I cannot get it “connects” on the Repetier software, but temperatures are zero and get a series of “Command waiting”. Also no FIRMWARE line appears in the logs.

The lights still blink as earlier.

I tested the Repetier connect on a windows and Linux machine, installing all the relevant software and usb checks / groups / permissions as required.

What else would I have to change / test?

Thank you,

  • w


In the Repetier software, select “Config” - “Printer Settings”.
In the “Connection” tab, you’ll see a line called “Reset on Connect”.
Be sure that this is set to “Disabled”

If not, you can get the problem you describe.

Thank you Belgian3d.

Set it to Disabled. The FIRMWARE line does not show up.

I do get a bunch of M codes in the log file
973 : N1 M110 *2
973 : N1 M110 *2
973 : N2 M115 *4
.050 : N3 T0 *25
050 : N4 M105 *3
051 : N5 M111 S6 *66
051 : N6 M80 *61
070 : N7 M105 *0
071 : N8 M105 *15
167 : N9 G91 *56

Do you have set on the correct COM port?
Is the Baud rate set to 250000?

Thank you Wrong Way,

On Windows, I reinstalled the FTDI driver and was able to:
Connect to the printer
Get the motors moving manually
Supply heat to the bed.
Supply heat to the extruder
Run the fan

Progress is good :slight_smile:

Thank you all for the help.

I will revisit the Linux connection at a later date. If someone has guidance on a particular Linux to use, I would appreciate it. I plan to use Linux Mint 64-bit.

  • w

One other point, I also downgraded Repetier (Windows) from 0.95F to 0.90C. 0.95F kept crashing, but that could be a case unique to my computer.