No connection wifi to WFS210 on IOS 10.01

Is there a problem with apple IOS 10.01? I can connect to wifi but not from wifi to WFS210.

We’re aware of this issue, we’re fixing it at the moment.

I’ve tested your new software for the WFS210 app (1.1.2) and it does still not work. After restarting my iPad it worked for a short while. I get the message “No connection. Demo mode is now running”. I have OS 10.0.2 on my iPad.

Go to wifi settings and forget the WFS210 network. Reconnect and it should work.

Iv’e have already tested that and it didn’t help. Still not working.

What a disastrous support for IOS users … I have product since two years and it is almost impossible to use due to constant SW issues in IOS app.
Have the same issue as “kosterlu” … need to turn on and off several times then it connects to network but it just works for less then one minute … then connection is lost and annoying demo mode pops again. App didn’t keep “disable Demo mode” toggle after restart , neither WIFI name …

I have the same problem, I still can’t get a connection with my Ipad Pro IOS 10.01
When will this problem be solved. This is very bad support of velleman!!!
They promis that the WFS210 will work with the IPad , thats why I bought it.

Have same problem, software runs in demo mode but cannot connect to oszi.
App doesn’t show up in the applist so it seems not to be registered. My iPad is an iPad Air.


Sorry for the inconvenience.
We’re busy trying to fix this problem.
It’s not an easy one.

Best Regards


We’re busy preparing a firmware upgrade for the WFS210 which should fix the problem

Best Regards,


Do you have access to a pickit3 or a programmer for programming PIC microcontrollers?


Do you have access to a pickit3 or a programmer for programming PIC microcontrollers?[/quote]
Yes I have,
Regards unclePP


I have purchased 2 of the wfs210. Although I find this product very interesting I have the same problem connecting with my ipad mini.

I understand you are working on a solution. What concerns me is when you talk about programming a pic controller. I hope we don’t have to get there and we can upgrade the firmware with a pc.

Looking forward to a solution


Any updates?

Still waiting!