Need example OCTO-PRINT profile

Hi all,

I am setting up the OCTO-PRINT Pi.
Installed everything (image) and it worked out of the box.

I do no like to kill my printer, so a single or dual head profile would give me a point to start from.
Actually, I am using S3D but I like to check the options and quality of OP :slight_smile:

feel free to share your profile with me :slight_smile:

Thanks in advance

What do you mean by the OctoPi profile?

I have used OctoPi with Repetier/Cura generated gcode for 6 months or so without any issues. I just put the gcode on an SD card and print from that via Octoprint. There are one or two bugs in OctoPrint with respect to reporting which nozzle is printing / temperatures etc, and sometimes you have to stop / start fans manually when you pause or stop the printer.

But other than that, it pretty much works perfectly as it comes?

Yes it works if u generate the GCODE with repetierhost/(cura/slic3r) but octopi comes with curaengine so it should be possible to generate the gcode by uploading only an .STL file.
BUT there’s 1 problem curaengine only accepts json formatted profiles and the ones stored in repetierhost/cura arent in JSON so you can’t just copy them over from your repetierhost => OctoPrint.
I’m playing around with the profiles myself last couple of days and one of the biggest issues is that there isn’t any support for dualheads I think at least not that I could find in 0.12.0

Kind regards

I played around with the software and I am happy so far.
I can upload my GCode, which was made by S3D, over WLAN and start the print. That is ok with me.
I have to check the prints and compare them.
At the moment, it seems they are different, but that was not proofed in detail.

Within S3D I have some props with heading the nozzles. sometimes they do not start when started with the script.
But started manually, it works and will be assumed by the printing job.
But that is something in general with S3D.


It would be great if either one of you could share your OctoPrint settings file.

I assembled my K8400 printer two weeks ago and have so far used it to print a 8 things or so from thingiverse, using Repetier software on my son’s computer running Windows 10. So far I’ve had these issues:

  • I got a bit late into the assembly process, and really late figured out that the bottom panel had been flipped - in any next design, please change it so that it becomes impossible to assemble panels incorrectly
  • one of the connectors on the board where you are to connect the second (left) temperature sensor was damaged and could not be screwed down to fix the cord, after applying indicent amount of force, trying things out, after some time we just moved along and temperature readings actully work (but it feels like it can fall out any day)
  • somehow, we managed to put one of the drivers in the wrong direction .
  • loading filament and trying to get it into the PTFE tube via extruder is a real PITA
  • the second print head (left) was 0.2 mm higher from the print bed than the first one (right), which made height calibration interesting - one ore two prints (using single filament) became a mess on the printing bed as the other nozzle got in the way. Used only the right hand one
  • both nozzles eventually clogged up - using default 210 degrees with PLA (black from Velleman) the filament melted too far up and left filament that wouldn’t melt or let new filament flow. Couldn’t unload filament as it was stuck.
  • cleaned both heads, but only re-assembled one (to the right) - kept heater and temp sensor from the other connected though so no errors in the LCD display
  • printed which looked great when I left it at perhaps 35% done (went to bed) but when it started out on the last 15 layers, the entire piece was moved and so the last layers where printed into the air

NOW for the OctoPrint thing:

  • Upgrade the Vertex firmware to 1.4 with 2 heads <- all previous prints was done using SD card, Repetier, and stock firmware (1.1)
  • Put latest stable OctoPi version onto a brand new Sandisk 8 GB micro SD card - About button under Settings shows: “Version 1.2.15 (master branch)”
  • Connected USB, power cables, flipped a power switch to get all devices to start
  • SSH in, resized partition, reboot
  • connected to OctoPrint via browser (octopi.local), setup username and password
  • expected things to work out of the box

Apparently, it does not.

  • I can’t find a suitable Printer Profile to download to get things started
  • change Connection settings to /dev/ttyUSB0 and 250000
  • Z axis moves the wrong way when using the buttons in the Control panel
  • reading files of SD card works all right, I can “Load” the files but when I hit the Print button, nothing happens and the LCD bottom line says “bitcoin.gco” (or whatever the file name is)
  • no auto home, no heating of extruder
  • at this point, I can go use the button on the side of the printer, “Print from SD” and the print starts just fine

Any help is highly appreciated!

Dear wendt_se,

You are trying to start an print job with a file located on the SD card using octoprint. That is what I understood and where I failed too.

In my opinion this is a weakness of the firmware, since I tried to command the print manually (by sending the GCODE with the terminal) without success, too.

However, this is an issue I don*t care about. When printing from SD card you have to write the card outside from the printer (otherwise you will get grey…), so it is no problem to start manually after inserting the card.