My printer stops when the project hasn't finished


I have my printer working. But one thing happens both on Mac and Windows. When I print an object that takes a couple of hours to print, the printer stops printing. Small projects come out the right way.

I switched off the sleep mode of my computer.

When the printer stops the repetier program does not communicate anymore with the printer. The fan still runs, but I cannot give any manual commands. The temperature window is frozen.

By the way, I use an USB extension cord (about 1,5 m).

Any ideas?


I had the same problem. It’s caused by the power supply.

The length of the USB cable should be no problem, as long as it doesn’t exceed 5m.
I use a 3m USB cable, without any problems, but with a different power supply.

[quote=“skywatcher”]I had the same problem. It’s caused by the power supply.

The length of the USB cable should be no problem, as long as it doesn’t exceed 5m.
I use a 3m USB cable, without any problems, but with a different power supply.[/quote]

Hi Skywatcher,

Thanks for your quick answer.
What power supply do you recommend?

Please try without the extension cord.

After i found out that the PS was the problem, i used my lab power supply and i never had any problems. But of course this is not really a solution for everyone because a lab power supply is big, heavy and expensive.

Using only the supplied (and VERY short) USB cable is no solution for 90% of all users, because they simply don’t have their PC so close to the printer.
And it’s also not necessary to use such a short cable, because the data rate between PC and printer is quite slow, compared to other USB devices (like cameras for example) which also work on a 5 m USB cable without any problems. And beleive me: the USB cable is not the problem. The problem is the power supply.


my printer seems to have a similar problem.

Sometimes it stops after just a few layers, sometimes when nearly finished, sometimes everything is fine. After stopping, control via Repetier-Host (0.90c) is only re-established after un- and replugging the USB cable and restarting R-H. At which point, obviously, the current process is lost completely, not to mention a nasty scar in the printed surface at the point where printing stopped.

The power supply is warm, but not hot (I would guess 35-40 °C).

Actually, just while writing this line (and feeling the power suppy’s temperature, nothing else touched), the printer stopped again. Maybe a cable break?

skywatcher: your lab supply probably shows the current used - could you give a number on that?


edit: running fine on a large lab power supply at the moment. Currents are (approx., at 15 V):
60-70 mA board
2.4 A heatbed
2.0 A extruder
plus several 100 mA for the motors (the internal ampmeter is too slow to resolve the pulses during movement more acurately)

I’ve seen on other posts it’s best to keep the power supply as far away from the USB cable and control board as you can

Did you replace the ferrite core on the power supply as instructed in the manual? The power supply is sensitive to interference, keep it away from any sources of interference.


I met this problem too, solution is definetly something with the cables.

I put the power supply far from every source of interference (mainly the computer) the usb cable is 5m long with a custom USB port on the electronic card because i broke the little one and everything goes well !
(20h working in a row without any interrupt)

Conclusion: look for any source of EMC and put it far from the power supply.

I’ve also experienced the same issue.

Two things I’m sure of :

  1. don’t plug the power supply in a surge protected outlet.
  2. check your USB driver (not the one needed for the printer but the USB driver of your PC’s mainboard). I had issues with my desktop and not with my laptop. Reinstalling a fresh USB driver on my desktop solved the problem.

I also had this problem a few times. Tryed many different things but never found a good solution.

What I think now is that it might be a hardware/software issue. When the printer stops (but hotend + extruder + motors are still on) you should try to press the OK button on Repetier host. This is in the manual control screen at the right lower corner with debug options. This ‘ok’ button “fakes” an OK from the hardware. I found this on the site from Repetier host:

The last button “ok” fakes a receiving ok from the printer. If your printer stalls, it may be simply because the firmware send an ok and only the o or k was received. In that case, hitting ok can restart the printing process. … l-control/

So I hope a new version of the firmware can solve this issue.


my power supply came with the ferrite already on the cable.
Is it necessary to replace the one on the cable with the one supplied in the package?


No it’s not mandatory, except if you have a lot of EMC problem. In the first time, you can try with the original and see after if it’s necessary toi change

For my part, I not replace it and I have no problem for 3 months.

Okay, so I’ve just replied on this topic in the other thread relating to it, but having just read through this one as well, and haing JUST watched my print job ‘crash’ for the second time - first time after an hour - this time after 10mins but I was in the room to see it happen this time, this is what happened:

For about 10s it just slowed and did very jerky, sudden moves, maybe only 5s now I think about it. Then it stopped.

So I tried the suggestion above about the ok button… IT WORKED!!

Obviously this is not a solution - of the 20 or so print jobs which have stopped after 10mins - 4 hours, over the last 2 months of ownership and the painstaking restarting of jobs after creating customised gcode to carry on, but backtracking a bit and cunningly faking rehoming without dislodging the print etc., of those 20 times this is the first time I have actually seen it happen, and it just happened to be after reading that ‘okay’ post.

Things I’ve tried so far:

  1. cooling the pcb and the powersupply with PC fans
  2. putting powersupply and pc / printer / usb / anythign else, as far apart as possible
  3. making crappy faraday cage from earthed silver foil box
  4. using an old laptop with XP, with ALL settings turned to max power and no energy saving or updates or anythign allowed
  5. ubuntu build on newish PC (i7, ssd, 16GB ram etc.) again very clean, no power saving, just the updates to the pc impersonating libraries to get repetier working

Very upsettingly I did have it able to do 15-20 hour runs for about 2 weeks, but its back to its old tricks AND I DON’T KNOW WHAT I’VE CHANGED!! So cross with myself for not being able to work out what I’ve done wrong. I have two physics degrees, a year of post-grad electronics work, 3 years tutoring mech eng, and 6 years working in I.T. You’d think I would have the skills to work out what I have changed to stop it working again. So annoyed with myself! Other than the stopping, this printer is just the best - reading about the issues people have with kit massively more expensive, I think this printer is really very well designed.

One thing I have noticed
I have 2 video cards in my machine
Turns out that since I installed the he software for the K8200 the video cards don’t get along
If I have the filiment view turned on it slows the printer and does give warnings in the log area
You may want to look at the drives or OpenGL for the video card