My printer is not detected by computer

I completed my 3d printer some days ago but in the final step where the printer gets connected to the computer via usb something is wrong. When i plug in the usb 2 leds light up but i get no sound from the computer to indicate that something was connected. I cant find any com ports in the device manager even tho i installed the drivers. the 2 leds dont blink or anything just a solid green and red light. I have tried different computer and usb cords, nothing changes. if a plug in external power a green led blinks a couple of times and goes of.
i have looked at the board but i cant see any bad solder or such thing.
Anyone idea what might be wrong?

This sounds like you have not loaded the drivers.
Did you go through the section “Using the Printer”

Loaded drivers? I installed the vcp drivers on the computers i tried with(win 7). are there drivers which i should load to the board? i have read the instruction several times and cant find any such procedure =/ . thanks for the help

If its any help, i just checked with my arduino, and when its plugged in i get a com port via usb-ftdi but nothing when printer i plugged in. i really dont know what im doing wrong.

Did you follow the instruction in this link?

Yes i did, however i get no com port in the device manager and the computer gives no reaction to the usb being connected.

Hi Ronnie,

sorry for the question, it’s just to be sure: you tested connecting to an Arduino with success, but the printer’s controller board does not show up as COM port - did you use the same USB cable in both cases?

Are there any indicators that something’s wrong on the board, like ICs getting hot for example?

When powered by the 15 V supply, the green LED (labeled LD1) blinks and then goes dark, that’s as expected. If you press the reset button (next to the THERM inputs), does the LED blink again? Any change on the USB LEDs (LD5 and LD6) from resetting the board?


it was a different cable as the arduino uses standard B-plug type, i have tested 3 different mini B-plug for the printer.

no components gets hot enough for me to notice it.

when reset button is pressed with power supply connected the green led blinks a couple of times and goes off, while the red and green led that lights up when usb is connected stay on without blinking through all the process.

i have noticed that 4 pins on the ftdi chip are bridged 16-17 and 23-24. 16-17 looks like its done on purpose but 23-24 looks like a tiny spec of solder high up on the chip pins, do you know if this is normal?

Thanks for taking the time,

Hi Ronnie,

the response (when you can call it that) from the board when pressing the reset button is ok, so the ATmega seems to be working.

As for your notes about the FT232R, I don’t quite follow you. Pins 25 and 26 are visibly bridged, both are connected to GND. Neither 16 and 17 nor 23 and 24 should be connected. Are you sure about your pin numbers?


This is strange.

When you go in to Device manager you don’t see any thing under Com and LPT ports?

You could try installing the drivers one more time.
This time right click on the driver file and select “Run as Administrator”
Use the USB cable that was supplied with the printer.

You maybe correct that the control board does have an issue.

What part of the world are you in?


I was a bit tired when counting pins, the pins 25-26 and 19-20 are the ones i meant to say with 19-20 looking like a very small solder bridge that is so small that i had too use a usb microscope to confirm that it indeed connects the pins.

I tried to install the drivers again, using run as administrator option and original usb cable. No difference im sad to say.

Btw im in sweden and bought the printer from a swedish seller on the net.

Im starting to think that the board might have some issue. ive been all over the internet and tried all the usual fixes for common mistakes and quirks multiple times.
i think i will try to get in contact with the velleman guys and see if they could have look at the board. I really got 3d printing fever by this time and got lots of models that would like to step out from the computer into reality =)

Thanks to all for the help i really appreciate it

Hi Ronnie,

even if it doesn’t help anymore with this board: pins 19 and 20 are on the same potential, so for those two pins it’s ok to be bridged. The connection is not as clearly visible as for pins 25/26, but it’s there.


Thanks thats really good to know, i was thinking if a possible time saving strategy could have been to disconnect those pins. if nothing else it puts my mind at rest =)

Does anybody know a email address to the service department?

I would like to send my controller board in for inspection but im having trouble finding the email address to velleman’s service department.
Im not sure what to include when sending it back and a bit afraid of not getting it back if i do it the wrong way.
Thanks in advance,