MK194N Is not working

This just started working but I am posting this in case to keep track of what was happening. So no need to reply I just want to have a running record.

This worked perfectly after we finished soldering it. Probably worked about 30 minutes. The led still comes on but there is no sound unless I put my ear on top of the speaker.

If I switch it on holding the tuner it makes a single beep, if I switch it on holding the volume up button it beeps twice, and it beeps 3 times if I hold in the volume down button. Not sure if this is some sort of setting or diagnostic. Doing the same with the presets 1 - 4 doesn’t do anything.

As it turns out it works sporadically. I haven’t been able to discover a reboot combination that makes it work but sometimes it does just work. It isn’t leaving it off for a certain period of time or leaving it on and waiting.

Any help would be appreciate!

Same here.
For the love of… I can’t get it to work every time. When it powers on and responds to keys, it then it works, memorizes stations, just fine.
However, turn it off and than on again, and that’s it. Nine out of ten times, just some noise from LM386 audio amp.
I’ve had checked with the osciloscope, PIC sends the clock to MM100-2, but nothing else happens.

I have a similar problem. Everything works; tuning, presets etc, but there is almost no sound unless I put my ear on top of the speaker.
To my idea it is all soldered properly and did some measurements following the downloaded scheme; this is showing 3.3V at the right places.
If anyone has an idea why there is almost no sound that would be great.

Is it possible to post clear images from the component and soldering side of PCB?

Best Regards,
Velleman Technical Support

I have uploaded an image and a small video showing it functions well although you hardly hear anything.

Files on https://easyupload.io/m/1edo1d

pwd: radio

Thanks.

Hello @Klaas
Good picture, and good video quality

Some soldering seems to be too large, have you a multimeter to check there is non false connection with continuity check ? as for some with too low solder material …
Have you try unplugin, replugin the ICs ? (some times simply a socket / IC false contact)
You could use an old toothbrush to clean the soldering projections …
Have a nice day !
Edit : No T1 and VR1 permutation ?

Thanks for the support sofar!

I did already replugin the ICs and checked the order of connections. Attached a picture of the front.

No T1 and VR1 permutation ?
continuity checks done?

I think the front image also shows T1 and VR1 are placed correctly.
I’ll do the continuity checks later, but thanks sofar.

1 Like

Here is the photo and the link to video about my MK194N:

Could you please advise me how can I repair it?
It is unlikely that I could carry around a hot soldiering iron with the radio :slight_smile:.
Thank you.

Hello @NikolaG
Good catch !
Bad SMD soldering or a defective/sensible IC ?

My thoughts exactly.
I did try to reheat it, but to no avail. Therefore, I believe it is just a bad one.
I wonder If Welleman would recognize this and send me a replacement?

You must surely make a replacement request for the complete kit via your dealer.
But let’s invoke @VEL450 ! to be sure !

Thank you. I have just contacted local dealer (chipoteka.hr), and now I wait for response. I hope that will go through nicely, and if it doesn’t, then I’ll contact VEL450…
Have fun!

The problem appeared to be due to a bad soldering of resistor R2.
After having fixed this the problem with the sound was fixed and the radio works perfectly!

1 Like

@ NikolaG,

Check if the transistor has not been mixed up with the voltage regulator, has the same housing TO92.
Not visible in photo.

Also check all soldering joints. See “Klaas” his solution.

@ Klaas,

Nice to hear it’s working now! :slight_smile:

Usually the cause is a wrong component placement (orientation), transistors swapped with voltage regulators TO92 and vice versa, and very often bad soldering.

A good starting point for leaded tin is +/-350 - 360 °C for stations with passive tips,
or 300 °C for stations with active tips. These temperatures are about 30°C degrees higher for lead-free tin.

Best Regards,
Velleman Technical Support