Mk193 problem!

I bought my mk193 yesterday and finished the soldering today.
Super excited i connected the battery and the lights starts flashing except all the lights on plane 1.
So after some research i found out that all the leds on plane 1 is wrong settled. so plus is to minus.
So after about one hour of fixing that i again connected the battery. Now they was flashing to but only a little bit.
But i didn’t mind then so i tried to connect to the computer. I installed the drivers and the program. Everything worked fine and i could even send my animations to the cube. Suddenly when i tried to send an animation to the cube the progress bar just stayed at 0%. So after 5 min i tried to stop the sending but the program refused. So i forced the program to shut down with the task manager. Then i tried disconnect the cube from the computer and connected it to the battery. Nothing happened… So i pressed the switch on the cube, still no reaction. Then i tried holding the switch in, suddenly the leds started flashing. As soon as i release the switch the flashing goes away.

note. One of the resistance is badly soldered on the PCB backside. I have soldered it better to the PCB;s front side.

My problems:

  1. Plane 1 leds are barely flashing.
  2. The leds only flash.

Images of the soldering:

Video of the flashing leds:

Sorry to say, but the solder jobs looks very poor.
Most likely, that is the cause of troubles.
We’d recommend to inspect and redo every single joint.
Make sure that enough solder is applied, without applying too much, and make sure it flows neatly.
Maybe gain some practice with dummy components before attempting ‘the real thing’.
Good luck and keep us informed.