MK188 not working under load

Hi! I can’t get my MK188 to work, when the relay activates, it give the pump 1 sec of power and same time it “clicks” and then turn off. I’m trying to use it with a water pump, and that has a max of power of 12V 11A. It says that 16A is max so it should be enough?

The relay works with no load but as soon as I connect the black minus cable thru the relay it “dies” when the relay activates.

I have a short clip of the event if that helps, here you can here the click sound in the begining, on my onedrive:

Edit: You can notice that the powersupply (that is an psu from a computer) turns off just when the relay switches, like it’s a short cut? But I have mesaure with multimeter and under no load I get 12v thru the relay. I have tried to power the pump with just the PSU directly and that works.

Have you tried a different power supply?
Or tried to run just the pump from the power supply?

Yes I already wrote that " I have tried to power the pump with just the PSU directly and that works."

Have powered them seperarly from same power source, it works but have not tried an other powersupply.

Dear Erikedlund,

Pay Attettion on the type of load you’re using! A pump is an inductive load.
A pump has the characteristic of quadratic rising torque.

The Start Current can be 3 to 5 times higher than the nominal current of motor (11A)
this for very short time at start.

Thus so, I suggest to use a separate power supply of 12V / min 55A for the pump. And a 12V / 500mA power supply for the MK188. Also use an additional auxiliary relay that can handle the very short start current (inrush current) (max 55).

Best regards,
Velleman Support.