MK139 Not Working!

I’ve just bought and carefully completed my MK139 clap activated switch kit.
It works fine, when I clap, the clap LED (LD1) lights up.
The problem is the relay LED (LD2) never lights up. I’ve got it set to turn on when I clap twice, but when I clap twice, it doesn’t do anything.
I’ve also tested it on the one clap setting, but it still doesn’t work.

Can anyone help?

Check if PIC receives +5V, GND and ‘clap’-signal. Remove pic and force relay out to +5V. If previous is OK, we must assume dead or empty PIC.
In that case, return PIC for inspection/reprogramming.

Thanks, but I don’t really understand what you mean.

Firstly, what’s the PIC and how do I check if it’s recieving +5V, GND and ‘clap’-signal?
Secondly, what do u mean by ‘force relay out to +5V’?

PIC = 8 pin µcontroller
Check between pin 1 and 8 if the PIC gets +5V
Check between (-) of power supply and pin 4 if the PIC receives a +5V pulse everytime you clap
Remove the pic from its socket and connect pin 1 with pin 7, the relay should turn on.

Please seek local help if the above is unclear to you

I had this problem and returned mine. They fixed it and sent back. Works like a dream now. Great support!