MK128 Kitchen Timer: dies when batteries run down


I have bought two of these MK128 Kitchen Timer kits from Maplin over the years - both have died when the first set of batteries run down (which happens to be long after the 1 year warranty that Maplin offers!).

Is this a known issue with this product? Given it cost £10, having it only last not much more than a year isn’t ideal :slight_smile:

[Having been reading about that ATmega328 micocontrollers today, it sounds like they have to be setup right to deal with power supply brown out - otherwise bad things can happen, including program memory being overwritten unintentionally. Could something similar be happening here?]


Please note that there is a two year warranty on all our kits (not on your assembly work).
Furthermore, there is no link between dead batteries and defective kits.
Microchip controllers do not suffer from the problems you mention.
There must be another reason, most likely a mechanical cause.
Check your assembly carefully, watch for broken tracks, loose pads, bend components, bad contacts, etc…
If you can provide links to HI-RES and SHARP pictures of solder and component side of your assembly, then we can take a look.
You can always mail us your kit for inspection/repair.


Sorry for the delay in responding, I didn’t get notification of your update even though I’m subscribed - and only just remembered to check back :slight_smile:

Given both units have died, any thoughts on what could be the common link? Some links to photos for one of the two timers below - see if you can spot anything, though all the soldering looks good to me - and this was working fine for best part of a year before dying.

Do you sell replacement pre-programmed ICs? If so, then ordering a couple of those seems like the best way forward - I can rule out any other problems.


Once again, it is impossible that a dead battery destroys a controller.
Check if the controller receives 4.5V when the batteries are inserted.
What could have happened is that e.g. a soldering perforated the black lead at the back of the battery holder, which could have caused a short.
Unlikely but possible.

Mystery solved - looks like it is a dodgy battery holder!

I’d already tested the power supply and found it put out 4.5V when I checked across the batter holder terminals, but checking across the chip’s #1/#14 pins it was reading a much lower voltage (1.5V). After some digging, I realised that the batteries are just making an intermittent connection - which obviously the capacitors were just smoothing out to a lower voltage.

Jamming a bit of tin foil in the battery holder at the positive end (of the cell at the positive end of the entire battery) has worked around the problem fine :slight_smile: