LAB1 - dial knob for multimeter not working correct

I own a LAB1, purchased in October 2010, so out of warranty. The dial knob of the multimeter section is not working correct. The 4 dial settings for the Ampere readings do not function, unless I keep on pushing the knob into the housing at the selected setting, which of course is not doable because I need my hands to do a measurement. All other settings work fine. I already took the multimeter section PCB and knob apart (ball bearing type of dial), cleaned the contacts and reassmebled everything, but no change.

Does anybody have a tip or suggestion? Are there spare parts for the multimeter section available?

We’d suggest to send-in the multimeter section for inspection/repair.
Repair cost will be very reasonable, as there a no expensive parts in this section.
Please return it to your distributor or direct to:

Velleman Projects Tech. Dept.
Legen Heirweg 33
9890 Gavere


I’ve got similar problem, in mine case it’s even worse, because in some positions screen goes off, and I cannot force it on by pressing dial. I’ve tried cleaning contacts, heating up solder joints, replace battery, etc
Another problem is display assembly, which is loose (nothing is broken).

Device was sitting on the shelve for last few years, before it worked OK.
I think receipt was lost some time ago but would like to pay for new DMM PCB, dial wheel/contacs and display assembly with shipping to Poland if it would be resonably priced (you wrote there’s nothing expensive in DMM).
I can ship DMM module, but I don’t think it would be financially viable to ship it to Belgium and back to Poland.

I hope you will find a way to repair my device. TIA!