K8800 - During bed levelling the head crashes on the bed

Performing the bed levelling the head crashes on the bed boumping and scraching the bed. I hope do not destroy the nozzle…
I cannot use the printer now and the support does not answer me.
The printer is only 2 months old and I have printed few test objects.

OK here are some suggestions:

  1. Always do the following calibrate steps before doing anything else, every time:
    a. Home
    b. Calibrate Height
    c. Auto Calibrate
    d. Save settings
    Bed levelling is normally added at the front of your print by Cura, but without all the calibration it often fails.
  2. If the levelling still fails, try a factory reset before doing all the above. Sometimes a dodgy Z stop setting gets stored in the settings and needs purging.
  3. Check your piezo sensors are working by tapping on the bed. The best place to check is half-way between each pair of sensors, about half the radius of the bed out - that is most extreme point the bed levelling checks. If the sensors do not appear to respond, try turning the sensitivity control clockwise - try about eighth of turn at a time.
  4. If your piezos still do not respond, contact support and request new ones.
  5. Watch out for firmware issues. None of the firmware out there is much good currently; the stock firmware is way out of date, buggy as heck and causes frequent gouges and scrapes; susistrollch’s is probably the best cut but she/he is no longer supporting his/her firmware and there are some funnies in the bed levelling there. However, I would check very thoroughly for other issues before considering non-stock firmware anyway.

Hi sgparry
Thanks for your suggestions.

I performed these steps:

  1. I verified the belts and the sensor.
  2. I reset the printer to original settings with this procedure
    Re-calibrate procedure:
  1. go to SETTINGS
  2. Restore failsafe
  3. Initialize EEPROM
  4. Store Settings
  5. go to Vertex Calibration
  6. Auto Home
  7. Calibrate Height
  8. Auto Calibration
  9. after message “Calibration OK” => Store Settings.

At the end of this procedure I run the bed levelling as you can see in this video

When the bed levelling ends the head does not return home but stops in top-right position.

After this test I tried to print a simple cube and when the head is at 130°C instead of positioning itself on the top of bed to continue the heating process, it crashed on the bed in the usual bottom-left position.

At the end I tried to tab on the bed as you adviced and I think the piezo sensor is not completely broken but not sensitive enough.

What do you think about the last marling version 2.x firmware ?
Someone says that this solves many problems.

Thanks in advance for your help.

1 Like

Hello @ubruno1313

We’ve seen your service ticket. We will reply as soon as possible.
But we are busy translating the update guide to fix bed level failure issues.

But in the maintime you can check this:

  • Check whether the edge of the “Buildtak” sticker (that is glued to the printbed glass) is cut off. This excess edge must be cut off!

  • Make sure the bed is not pinched by the 3 grey alignment studs. It should fit with a bit of clearance so the calibration routine can nudge the bed slightly. If however (due to manufacturing tolerances) the bed is pinched tightly between these studs, scrape a small amount of plastic from 1 of these studs until the bed fits loosely.

If these are oké, regarding your uploaded video here, the cause could be piëzo failure.
The one where the head crashes.

Best regards,
Velleman Technical Support

Yes, support are right about the buildtak - you have to cut it back to the edge of the ceramic disk with a craft knife - it is about 3mm radius too big and catches on the stops preventing sensors from operating.
The build levelling does not home because it is normally intended to be followed immediately by main print.
I would avoid new firmware until everything else is sorted - it will not probably fix these problems.
I will check your videos later to see if I can tell why the build fails.

Hi I cut the buildtak edge but the issue is not solved as you can see in this new video.
Now I think it’s necessary to replace the piezo sensor.
Pls I ask to support @VEL450 how can we proceed?

Hi @ubruno1313 ,

We will proceed this further in the service ticket you’ve made.
My colleague from customer service will contact you further, regarding the spare part arrangement.

Best regards
Velleman Technical Support

Hi @VEL450 Thank a lot :+1:

Hello @ubruno1313

We have already notified Spin Electronics.
We send the spare piezo sensors to your purchase point Spin electronics.
Spin will notify you when you can pick it up there.

Best Regards,
Velleman Support

Thank a lot

I’ll contact SPIN

I have just received replacement piezos too, but I have no instructions for fitting. What is the procedure please? How do you detach / reattach them? The sensors seem to have what looks like solder paste or thermal paste on the underside?

Hello @sgparry

To remove and replace the Piëzo sensors, see the illustrated base assmembly guide here, via this link: https://velleman.bitrix24.eu/~OXgZh . Follow from page 24.

To remove, simply pull the piezos from the stickers.

Best regards,
Velleman Support