K8400 display stopped working (only squares)

I purchased the K8400 printer a three months ago. I assembled it with no issues and I have happily been using it since then.
However, suddenly the display has stopped working. I have made absolutely no changes or modifications to the settings but the display now shows only two rows of “bright squares”.
When controlling the printer from the computer everything seems fine. The control wheel also seems to do at least something but whatever I do the display only shows the squares.
I have checked the cables and also successfully reloaded the same firmware (latest). Contrast adjustment makes no change (the squares go away when i turn it counter-clockwise).

It seems likely to me that the LCD board is faulty.
Is there any way to confirm this or is there something else that I should check?
Shall I return it for repair/replacement?

Best Regards,


In my display assembly the spacers between the two boards were too long (or the contact pins too short). It shows nothing after I mounted it to the case.
So in your case I would check the display assembly without the distance bolts.Eventually there are one or more pins with no contact.

Thanks for the reply, mcguiver!
You have a good point. The spacers on my unit are also too long. I took apart the assembly and I was then able to push the two boards together a bit.
However, this had no impact on my display which still only shows the same thing as before, i.e. two rows of squares :frowning:

Again, my situation:
Everything, including the display worked fine for three months.
The display has now stopped working; I think everything else is OK.
When the contrast adjustment is turned counter clockwise the display is all blue (nothing is displayed at all).
When the contrast adjustment is turned clockwise the display shows two full rows of squares - nothing else.

Have you reflashed the firmware in between?

IF you are sure that the display is faulty you can create a support ticket here:


I have reflashed the firmware; no problem at all.

I have also brought the whole display assembly to a friend who has the same printer; to my surprise my display assemply worked fine with his printer!

The main suspects now are of course either the flat cable or the motherboard.

Is there even a remote possibility that some other component might cause this behaviour?
To narrow down things I am thinking of removing all connectors from the motherboard except for the power supply and the flat cable to exclude all other possibilities.
Is it safe? Should the display work in this setup, i.e. show the usual text message at startup?

First thing to remove : the reset button… Might be stuck.

BEL did you find a solution?

i have the same Problem.


An LCD showing only squares means it has not been initialized properly.
At startup the LCD receives a set of commands that tell it what what it needs to do before it can display anything.
So 3 things can be wrong. Either the PCB on the LCD itself is broken. The microprocessor driving the LCD is broken, or the wiring in between.

So basicly, it’s a hardware problem. No firmware is going to solve it.

good luck.

It can happen when the reset button is permanently pressed. Check the reset on the LCD panel : the right acrylic panel can press on it if the button isn’t perfectly centered in the tiny hole.