K8096 : MOTS2 stepper always rotating counter clockwise

Hello
I try to have my K8096 Board + MOTS2 (ST35) working, but the MOTS2 stepper is always rotating counter clockwise. I already spent two days on this problem.
Velleman Driver is loaded ok (version 5.1.2600.0)
I use the Demo software. Every feature seems to be ok. The inputs are activating each feature (rotation, torque, etc), but stepper is always one direction if I click on Left or Right. Torque works and but has no effect on rotation direction.
If speed is set too low, stepper don’t move (normal behaviour)
Stepper connection : I use 4 wires (Blue, pink, Yellow, orange), knowing that Red an Brown are of no use in this case.
Power supply 12v AC : I change it (I know it’s silly, but …) , same result? Tried also with 24V AC
COM PORT: whatever the COM port is (COM3, COM4) , same result
I triple checked all component soldering and component places, removed ICs from sockets and plugged them again : no errors, but same result
I checked manually the MOTS2 with a separate 12V DC power supply, activating each coil one by one. It can rotate in both directions
So I’m stuck.
Any idea (apart from a defective driver L6219 ) ?
Thank you
PAA

Hello,

I think your problem is wrong wiring. or the motor coils are connected anti parallel => opposite phase.
The correct way to wire a bipolar stepper motor is as follow:

image

For MOTS2 unipolair stepper motor connect it as follow.

Interesting sources:
Wiring Basics: Unipolar vs Bipolar (orientalmotor.com)

4, 5, 6, and 8-wire Stepper Motors : 9 Steps - Instructables

How a Stepper Motor Works - HowToMechatronics

Best regards,
Velleman Support

Hi VEL 450
Thank you very much for taking time on my problem.
Unfortunately, I think I had the MOTS2 connected correctly (but I may be wrong ?).
To help both of us, may I send you photos of my board (component side and printed circuit side), photos of motor connection (both ways), and a short film to show you the motor behaviour along with software usage?
Best regards
PA Angelini

I checked again MOTS2 connection. It was already connected as you said it should be. I had found those information on the forum previously. Any other ideas ?
Best regards
PA Angelini