K8076 and Windows !0

I have had this kit for some time and it has always worked well but I now find that it will not program a pic PIC16F628A.
The programmer recognizes the pic and seems to be OK but when I try to write to it I get “wrong Pic” come up on the display.
I have not used it since upgrading to WIN10 and wonder if this could be the problem. I have done a search but not found anything that gives me any clues to the problem.
When I run the program and ask it to auto detect the type of PIC it gives me the correct answer.
I am at a loss on how I can resolve this problem.
Any help would be greatly appreciated. I am using ab 9pin to 9pin RS232 serial cable not a USB to RS232.

Did you go under “Function” (top of the screen) then “Hardware Configuration” and select the “VM134 K8076”?

Hi I have been downed by the Flu so now back programming I hope,
In answer to your post yes I did select from the menu the programmer in the way you described. I still have had no luck in getting it to work. I know the port is working as I have my frequency standard monitor run through it to make sure I was not making a simple error.
I have no way of testing it by using another computer as the laptop only uses USB connections.

This maybe a long shot.

I have seen where others have used Winpic.
I don’t know if it will work on Windows 10 or even where to download it from.
You will need to do a search.

Did you try using the slowest setting for the pic programmer?