K8061 CPU fail message


I’m working with the K8061 extended interface board, I got it work with my PC, but the problem is when I run either the diagnostic tool or the demo tool included on the CD the both say the cpu failed. I read some posts on this forum that said it might be to do with the voltage so I checked the voltage from the regulator is OK (12V on pin1, 5V on pin3) but the voltage on ic6 (11 and 32) is NOT at 5V. Pin1 is ok 5V.
IC1 and IC2 are in the right position (opposite).

I have checked a lot of solder points to make sure and that all seems fine, I went around the board with my multimeter checking the connections as well and all seemed fine.

Can anyone give me some advice on what I need to check next, or is there anyway to check if it is the chip that is not working or something along that line.


[quote]but the voltage on ic6 (11 and 32) is NOT at 5V. Pin1 is ok 5V.[/quote]These pins (1, 11, 32) are connected together on the board. So the voltage on all these pins should be equal.
What is the voltage on the pins 11 and 32 you got ?
Did you measure the voltage on the top side of IC6?
If yes, maybe there is some problem with the socket…

I confused the pin numbers… Now I measured on the top side and on the back side of IC6, it is the same result: 5V on pin1, 11 and 32. So this is ok.

I didn’t precise the status of the LEDs:
-When I connect the power supply, all digital inputs are on. But LD 11&12 are OFF.
-When I connect USB, LD 9&10 are ON.

I think I found the origin of the problem: I connected a 5V source on the clamp of DO 5-8, but when I did so, there still was a 12V source connected to the clamp of DO 1-4. The 5V came from the output of the voltage regulator VR1.
So I accidentally short-circuited the 12V clamp and the output of VR1, and so pins 1,11,32 at IC6 were at 12V, too.

After removing the 12V at clamp of DO1-4, I get at VR1 12V and 5V this is ok, and at IC6 pins 1,11,32 are at 5V again which is logic, but CPU fail message remains and LED status is as described before.
Did I break the CPU by applying 12V to pin1? :S
Or is the problem coming from IC1 & IC2?

[quote]Did I break the CPU by applying 12V to pin1? :S[/quote]I’m sorry, but it seems this may have happened.
-When you connect the power supply, all digital inputs are ON, LD11 is off and LD12 should be blinking.
-When you connect USB, LD9, 10, 11 and 12 should be ON.

You can return IC6 for check/replace to:

Velleman Kit Tech Dept.
Legen Heirweg 33
9890 Gavere

Or you can contact your local Velleman dealer.

Ok thanks, that’s what I feared. I’ll look for a spare part for IC6.
Thanks again for your support.

IC 6 is a programmed IC.
You will need to get it from Velleman.

I found a similar card, so I took the IC6 from the other board and it works again, so the board is still functional. I was thinking to purchase a PIC16F871 and to transfer the program from the working IC6 on it. (in order to save time)

The PICs on the Velleman kits are read protected.
If you try to copy it you may destroy it.