K8055 - HID Fails to start Code 10 Support Call


we have two K8055 USB Experiment Interface Boards in our company and we have a problem:
one of the two boards runs correctly on all of our system, but the other one just runs on some PCs and only sometimes at randomly.

If we disconnect it and reconnect it again on the same usb-port it don’t work,
Devicemanager shows “device fails to start (Code 10)”, restarting the pc don’t change anything.
If we connect it to another port of the same pc it works (sometimes ?!?)

We tried to run it over a USB hub with external power supply,
there it works more often than on the USB ports of the PC.

The usb-cable is ok, we tried it with the other board.

Now there is the question if this problem allready is known and what we can do to get it run?


btw: the pcs in our company runs w2k SP4 and XPSP2, same problem on all systems.

You may check if the microcontroller IC3 is defective.

  • Change the IC3 from the defective board to the good board.
    If the problem is transferred to the good board, then IC3 is probably defective.
    If not, then there may be some soldering fault or wrong or defective component on the defective board.