K8055 board not working anymore

Hi everyone,
I have a problem with my brand new K0055 board.
I just finished soldering every part of it and the board was fully working yesterday (even with a program written in Excel…).
But today, when I plug the card, the LD8 lights three times and then does not stop lighting. My PC make the usual sound when I connect a new USB device.
But after that, My PC does not recognize the board (error message about the USB device)

For your information, I use windows 7 Family edition premium with SP1 (64 bits) with the 4.0.0 SDK

I am quite worry about that, because my board did fully work yesterday…

Thank you for your help !



This is very strange problem.
Have you tried to connect the card to other USB slots of the PC?
You may also try with other USB cable.
If you have possibility to test the card in other PC, this will show if there is problem on the card or the problem in the PC (possible driver problem).

Hi VEL255,
Thank you for your quick answer,
I tried to connect the cart to other USB slots, I have a usb Hub (D-link DUB-H7) and when I plug the card on it or on other USB slots, the board does not work.
I tried to connect with an other USB cable, and it does not work. the cable itself works (HDD USB cable)
But I tried on an old PC (Win XP SP2) and the board is working very well.

I found a solution on my “new” PC (Window 7) : The board work again but only when it is plugged with the USB port which links my hub to the PC… It is very strange.
So :

  • Do I have to conenct the board always to the same USB port on the computer ?
  • Is there any limitation (maybe on the output current) by changing the usb slot ?

I plan to have 3 other board, and I will need an USB Hub to work with the boards. Is there some known problems with USB hubs ? then what hub could I buy ?

Thank you for your help !

[quote]Is there some known problems with USB hubs ? then what hub could I buy ?[/quote]Your problem is very strange. There is no known problem with the K8055 using the HUB. The cards should be connected to any USB HUB.

I think there is something wrong with the USB HID drivers of this PC.
You may have to “reset” the USB drivers of the PC.
Please see this link how to proceed:
“Fix Windows 7 “USB Device Not Recognized” Error”
windows-exe-errors.com/fix-windo … zed-error/

Hi VEL255,
Thank your for your response.
I tried today to shut down my PC and to unplug it.
When I started the PC again, the Board works again with my hub.
It seems that there is, as you mentioned in your post, some problems with the USB drivers on my machine.

I think you found the right solution for my problem.

Thank you for your help,