K8048 PIC 16F84A PIN 18 not connected

Hello Everyone,

I wonder if someone can help me with this problem. I’ve just brought the PIC Programmer KIT K8048. It worked perfectly, I’ve managed to successfully program a PIC 16F84A chip, but when I run the Demo2.ASM Program I noticed that when I press SW2, nothing happens. When the other Switches are pressed, the LED flash with different effects accordingly. I thought it was my soldering at fault, but I found that PIN 18 on the 18PIN socket (RA1 on the PIC16F84A) was not connected to anything on the PCB. I could fix this with a link wire to the SW2 (via R26). But is this the right thing to do?

The example program was written for this board (8048) and for the included PIC controller 16F627, so that’s the reason.
If you want, you can connect another pin, but you must avoid that 2 pin’s from your F84 are connected to each other.

Actually, Pin 18 of the 18-pin socket is supposed to connect to SW2 (check the board schematic in the assembly guide). The trace is not on the bottom at that pin, but on the top (under the socket). You must have an open connection somewhere. Test for connectivity between SW2 and pin 18, and the 3 vias between them. Or maybe your SW2 is bad.