K8048 - no pic on board

First all, hello everybody and sorry for my poor english.

I’m a newbee with a recently bought K8048 board.

I took it and installed VELLEMAN PIC Programmer 2.6.0, PicProg2006 (both included in the CD) and MPASM, downloaded from Microchip official web.

OK! I was quite happy and all software run without problems.

I’m following the user manual at http://www.velleman.be/downloads/0/usermanual_k8048_uk.pdf.

I mark K8048 Compatibility in the Function menu in PicProg2006 and open PIC Programmer 2.6.0. I can load demo1 program, (included in the software), select COM2 connection (status field shows ‘K8048 detected’), controller is selected correctly (PIC16F627). Now, I click in the ‘Write’ button and the app shows me:

My board is set in Program Mode, PIC is in 18P, jp3-jp4 ON, PIC type is not wrong and no other IC inserted.

Power led is enabled and LD9 is flashig, but LD8 (read/write) is permanently disabled.

I’ve tried with save and verify buttons with the same result.

I’m using DC9-DC9 connection and a 12V-500mA DC power supply, my multimeter shows 20V DC…

What is wrong?
How can I solve this problem?

Thanks all in advance.


Hello all.

I solved my problem… my board had a bad connection and the power was not reaching to the PIC.

I repaired it and all is working fine now.

Thank you very much to all.


I also have same problem, almost. the read write led comes on when I try to program it but it also displays NO PIC ON BOARD, PROGRAMMER MUST BE SET TO PGM MODE, PIC TYPE MISMATCH WITH SOFTWARE, …
I am very new at this, any help will be apreciated