K8048 does not seem to be working at all

Hi. I just completed building the K8048 kit. The assembly looks good, all parts in their places, voltages are good., but I get a “K8048 Not Found” message or “Failed to Initialize” when I run the program and try to “talk” to the board. I have a good connection with the RS232 cable- after a little board trimming- and am using Com2. The serial cable works fine for my Basic Stamp programmer. I’m using a PC running Windows XP. (com ports are automatically configured). I have done several electronics projects, but this is my first PIC project-ever. Any help will be appreciated! Thanks! :neutral_face:

Update: I found I was getting no signal from the 4Mhz crystal oscillator on the K8048 board. Something is loading it down. I got a good clock signal when I tried the same PIC chip in another board that used a canned oscillator (4-pin device) for the clock. I will first try different values for the crystal bypass caps- 22 or 33pF -and see if it runs. If that doesn’t work I will try adapting the K8045 board to use the canned oscillator and see what happens.

:slight_smile: In case anyone else actually reads these, this may be helpful.
I finally got my K8048 going by replacing the 4MHz crystal and 18pF caps with a 4 MHz “canned” oscillator (4.000MHz ESC-100AC) I got it from DigiKey, but there are other sources.
The oscillator has four pins, but only three are needed. Pin 4 is Vcc, Pin 2 is ground and Pin 3 is the clock output that connects to Pin 16 of the PICs. Pin 1 of the oscillator is not connected.
Pin 15 of the PIC can be left unconnected. (This is how the canned oscillator is used on a PIC Demo board I have).
Carefully remove the crystal and two caps. The oscillator device can be “dead bugged” onto the board where the crystal and bypass caps used to live. I used double-sided mounting tape to secure the oscillator to the board, and connected it using #30 wire-wrap wire.
I also found that I needed the correct 9-pin serial cable. One of the cables I used caused the “K8048 not found on Com 2” message. I found that pins 1, 6, 8 and 9 did not connect through from end-to-end.
Fortunately, I had another cable that worked- all 9 pins go through. Now to learn about programming…
Hope this helps! Dave.

Hi I’m getting a ‘COM-Init-Error’ message.

Is that the same as what you had?

I was getting a “K8048 Not Found” error the first time I tried running the board. That was caused by an old cable that did not have all 9 contacts connected through. 4 contacts were open. A fully connected RS232 cable solved that. The “Com-Init” error may be cable related, though I can only guess. Sorry.