K6501 does not work on line

After built and acurate control nothing is wrong on the electronic device. T7 is in right position.
DC line used is 11.8V CC directly after the AC diode bridge. (I tried also 12V, 12.8V 13V cc)

Channel 1 (and the other) is working correctly when pushing manual switch. 1 time relay #1 is on 1 time again, relay #1 is off ; 2 time relay #2 is on and so on…
I plug the phone line and power the electronic device with 11.8V DC 300mA.
After calling, (10 tones), I have an answering machine which says me “Enter your code”.
BUT the red LED does not flash and the relay RY1 stays Open.

And on another hand, my is code “00” (all straps for code opened) followed by 1 (relay numer) then 1 (relay On) but nothing happens.
I tryed to reverse the phone line in its connector ; always nothing…

Where could be the problem ?

Thanks in advance for a replay

It sounds as if you have voice mail set up on the phone to answer after 10 rings.

You should try to set the K6501 to answer after 3 rings.

You are right. it’s my answering machine which trig on after the same number of ring even when this machine it is off.
I already tried with 3 rings and the K6501 does not work better.

A more accurate observation with an oscilloscope on the telephone line leads me to analyse more precisely the opto-coupler. The input signal was ok but, output signal toward RTCC data input of the PIC was not correct. I thought that this optocoupler was out so I tried it alone and out of the board. It was working !!
Finally I founded the problem which was a bad contact in the socket of this opto coupler. I put a tulip socket and now it’s OK.


Glad to hear it’s working.