K2633 no relay switch


I build the K2633 4xrelay card and attached it to the K8055.
When i send to my digital output the LED on the K2633 goes on, but my relay’s won’t switch.

I measure a voltage of only 0.01 V on the base of the relay.

relay: SRU-06VDC-SD-C
power: 9VDC

The board is assembled exactly according to the instructions.

Any idea what might be wrong?

And where can i find more info about the relay?

Many thanks in advance,

Can you provide details on how you’ve hooked up both kits ?
Does the relay card work when you short the inputs to GND ?

Well my connections are straightforward:

K8055 K2633
(USB) ( power 9vdc on VDC input)
GND ----------- GND
CLAMP -------- +VDC
DO1 ----------- 1

Getting the GND from K8055 to input 1(etc) on K2633 does nothing.

Is there another way to test the relay?


The USB may only go to the PC, you may not take power from this connector.

You must connect as follows:

External 9V adapter --> VDC connector + and -

When you short circuit ex. IN1 with GND on the relais card, the relay must working.

Now connect IN1 of 2633 to --> OUT1 of K8055,…2 -> 2 ,…

Success !

I did not use my USB as power.
My post changed a bit in the editor. I meant to make a sort of table:

K8055…|… K2633
(to USB)…|…( powered by 9vdc on VDC input)
GND ------connect------ GND
CLAMP ----connect----- +VDC
DO1 ------connect------ 1

Which is what you say.

(So i did that wrong before)
Now I did that for every IN: the LED goes on, but the relay’s is not closing.
Then: Voltage at the base of the relay becomes: approx 0.28 V


Try replacing R5…R8 with 1K resistors.

Well now it works!
Voltage at the relay base becomes approx 5.9 V.

Thanks a lot!

You can hear me singing again…

Hello again.

I thought it was solved, but only 3 of the relays switch now.
There is one relay that does NOT switch at this voltage of 5.9V.

It first I thought it was broken, but only when I apply directly 12VDC to the base it switches. A voltage below that and it does not close.

Do you know a solution for that?


Try replacing the transistors of that particular relay.

Replace the transistor with what?
It doesn’t seem to be broken…
Now PNP transistor : BC557B

Have you checked the transistors ? If so, how did you check them? They are the only active parts and they cost a couple of cents…

Well I didn’t check it, but the circuit for that relay is behaving exactly the same as the other lines. So i find no reason to think it is broken.

The problem is the voltage at the base of the relay is not enough to close it.


Thank you for the suggestion. I tried it.

I replaced the transistor, but the behaviour remained the same.

Because I need this solved fast, I replaced my relay2(the not switching one) with relay1 (working OK).
Relay1 is switching in the place where relay2 “no switch” was.
Relay2 is not switching in the place where relay1 “yes switch” was.

I think the problem would be solved, if I could get my hands on a relay that is behaving just like the other 3 ones.

So far I found no datasheet on this relay. So I am bound to you.
I don’t mind paying the cost of a relay. I also have no problem sending the relay to you for checkups.


As you’ve stated that the relay worked correctly when you removed it, I had to assume that the relay was OK.
In order to protect your privacy, do not supply an address here. Use the support form instead. Mention the problem you experience, so we can mail you a spare relay.

Where do I find this support form?

Thanks for your help.

velleman.be/be/en/support/su … duct=K2633

I ordered and received two these relay boards and initially had the same problem. What I found was that you had to increase the voltage in to 12 VDC. Relays work great when I did this.

Are there any elelctronic relays that will replace the relays on this board?

Sorry, not in our range of products.