K2400 Bright digit Clock

i’m trying to compile the above project without success…
the following error is still there. Can anyone help me? thanks alot


It would be easier to debug if you could provide the working code (even partially). Nonetheless my first guess would be to write it like this:
RgbColor color(0,0,0);

Hope it helps.

Hey! Thanks it help’s, but… the next error… :roll_eyes:

I take the orig. Sketch from Github
I think it’s not ok when i post the completely code here… i didn’t find any option to upload the sketch…

i upload it to Dropbox: https://www.dropbox.com/sh/gctq958mohbs649/AADsMegHUK9YeXH3e0r9pedxa?dl=0

thanks a lot!


I just tried compiling everything and it works.
What errors do you have now?
Is everything the latest version?

Thanks for Reply.

The Following error are now:


Only the Json Lib is ver. 5.xx (new is the 6.xx)
all other lib’s are up to date.
Which Board to you compile? i’m take the wemos d1 mini esp32
but also with other esp32 boards the same error.

so i think it must be a config error…
perhaps you can send me the correct board settings?

thanks a lot

I used esp32 dev module.

But that error seems fimiliar…
I’ll check must be something with the libraries

EDIT: i have v2.2.9 of the NeoPixelBus please check what your version is? You can find it in library.properties file

i use the 2.5.0 version.
i try it to downgrade to 2.2.9 but it sucks…
after that it tells me again 2.5.0.
then i delete the lib in the folder , in arduino it’s still there with version 2.5.0 Strange! :face_with_raised_eyebrow:

i can’t select an other version to install…or delete it completely…

BTW: when i will downgrade, i can only downgrade to 2.5.0! so, i think i must manually install the lib 2.2.9. but i can’t find the version…

i found the lib and install it.
the lib manager tell’s me, i have installed 2.5.5
when i want to downgrade to 2.2.9 it tell’s me already installed.
but the compiling error ist still there…

Here are my libraries
Please try these

with this lib’s, i have another one…

the return must be boolen, so i think “false” is ok. i try some other options but still stop compiling at this point…

please use this

same error (on 2 diff. Notebooks…) :kissing:

That’s not normal…

Maybe try different board settings or update your Arduino ide.
Maybe you have different versions of a library and the compiler is confused or uses the wrong one.

i’m trying now another Notebook and install all again…now it works! with the *.ino file here from a prev. Post.
No idea what happens here!