Issues with K8200 control board


I’ve recently assembled a Vellehman k8200 which I got from your Australian supplier (JayCar) and I have experienced some issues with the control board(i.e. the modified Arduino board with the Pololu motor drivers on it).

I had assembled the frame, wired up all of the stepper motors, adjusted the voltages on the motor drivers and installed the software. However, when I tried to get the unit to move with Repetier I had no luck. I checked the current consumption from the power-supply with a clamp meter and noticed that even though no motors were moving it was drawing a couple of amps. I checked the board with an IR thermometer and the 7805 regulator seemed to be extremely hot.

The next step I took in troubleshooting was to remove the motor drivers. This instantly dropped the current consumed by the board to almost nothing and the board correctly connected with Repetier. I then tried reinstalling the drivers one-by-one and it seems that the X, Y & Z channels all worked and all of the wiring for the X, Y, Z and extruder motors was correct. The problem seems to be the extruder driver, whenever it was attached to the board the 7805 would get extremely hot and the unit seemed to not connect with Repetier. I also tried putting a functioning motor driver in the extruder’s slot and, while the 7805 did not get as hot or draw as much current it will not run. This, to me, suggests that there was an issue with the motor driver for the extruder and it drew so much current from the atmel chip it killed an output, but that’s just a guess.

Could someone please inform me of what steps I should take next. I’m not sure if there are more troubleshooting steps I can take or if it is a question of having the board replaced under warranty.


We’re afraid such a problem is not user-servicable.
We’d recommend to return the board to your distributor or direct to:

Velleman Projects Tech. Dept.
Legen Heirweg 33
9890 Gavere

Make sure to include a detailed fault description.

I would like to ask to technical support or somebody who know something about this problem. I finished my build of the Valleman from kit. I have one malfunction - the extruder thermistor indicate 143,5C . When I start the extruder heating - temperature on extruder goes up , but Repertier indicate me still 143,5C when actual temperature is approx 200-230C. Internal resistence of thermistor with cable and connector is 130k/Ohm. Please tell me where is the problem. Thank you.


Please post your question in a new topic

Best Regards,