Isn't moving just shivering

Hi!

I have download the example code for the VR204 (two leg) robot and it work fine when i don’t use IR-transmitter. When I change “IRreceive boolean = false;” to true and download the program to the robot again, the robot starts to shiver like it´s trying to make some movements or something. I try to press buttons in the allbot app on the mobile but nothing happens. I have tried to high and lower the volyme (the IR lamp indicate that i press buttons). I don’t know if I have missed something, i am new at this, any ideas?

Ps I have a mega-card not UNO, can that be a problem?

Yes check if the pins correspond with the one you’re using in your program.
Also move the blue shunts accordingly

I have checked that the pins is consistent with the Code and the blue shunts is in mega position. But i have still the same problem.

BOT.attach(hipLeft, 32, 90, 1, 0);
BOT.attach(hipRight, 24, 90, 0, 0);
BOT.attach(ankleLeft, 33, 90, 1, 0);
BOT.attach(ankleRight, 23, 90, 0, 0);

The robot works well when I not have IR enabled.

I have the same problem, but on an Uno board. Demo mode works great, but when I switch to IR nothing happens. I pulled apart the IR unit and it has the correct solder.

The app I’m using is the iPhone one. The IR dongle lights up.

I have two robots VR204 and VR408. I have the same problem. Demo mode works, after switching to IR nothing. The LED on VR001 is working properly and the IR LED is also working.
There is the same problem on both robots. I’m using Arduino UNO and Samsung S5.
Sorry, I’m from Poland, I know English on average, please help me solve the problem with VR001.
Greetings

Hello All,

Please check this:
https://manuals.velleman.eu/article.php?id=407#Code

Allso this for iOS or Android devices:
Check if the volume is not set to high on phone or tabled!

IOS DEVICE:

  1. Plug the VR001 into the audioport of your device.
  2. Make sure your device is not set to silent/vibrate.
  3. Make sure your device is not set to use EQ sound enhancements in the Settings -> Music -> EQ menu
  4. Open the ALLBOT application.
  5. Adjust the volume to 3/4 of maximum and check if the light on the VR001 flashes when you press a button in the application. Increase or decrease the volume until the light flashes when you press a button.
  6. Start your robot (make sure the IR RECEIVE/PROGRAM switch is set to IR RECEIVE).
  7. The robot should know execute the commands you send it by pressing the buttons in the application.

ANDROID DEVICE:

  • Plug the VR001 into the audioport of your device.
  • Make sure your device is not set to silent/vibrate.
  • Make sure your device is not set to use any EQ sound enhancements.
  • Open the ALLBOT application.
  • Adjust the media volume to maximum and check if the light on the VR001 flashes when you press a button in the application. Increase or decrease the (media)volume until the light flashes when you press a button.
  • Start your robot (make sure the IR RECEIVE/PROGRAM switch is set to IR RECEIVE).
  • The robot should know execute the commands you send it by pressing the buttons in the application.

If the robot is not doing anything or if it only works sometimes, try decreasing the (media) volume of your device. Also make sure the IR receiver on the back of the robot can “see” the VR001.

Don’t forget in Sample / demo code to set the IR device ON! how to do this:

Search for the line of code that contains:

 boolean IRreceive = false; // Set this to true if you want to use the IR remote 

If set true => IR is ON, working. IR receiver on shield is responding on IR transmitter.
if set false => IR is OFF, not working. IR receiver on shield isn’t responding on IR transmitter.

Best Regards,
Velleman Support