HPS140MK2 rebooting / shows voltage when unconnected

I bought a new HPS140MK2 a couple of weeks ago. It worked well since yesterday. I did not use it for like 3 days, It was lying next to my development table. The place where it always was, nothing dangerous or something. Didn’t throw it on the ground or left it switched on for a long time.

The behaviour now is: swichting on - shows boot screen (firmware 1636) - shows oscilloscope screen a for a quick moment - seems to crash - shows boot screen again - and again - and again.

sometimes it will stay at the oscilloscope screen - but then shows a DC voltage of some Volts, like 10 Volts, 6 Volts, the value is different each time but then stays. Event when there is nothing connected - no probe, nothing.

when i try to measure something it seems to add up to the already shown value on the screen.

I was thinking about just replacing the batteries, but didn’t have some at hand at the moment. Could batteries be the cause for this behaviour?

thanks a lot

You should try new batteries to be sure.

guess what? Certainly it was the batteries. Changed them and all good.

Nonetheless I find it a bit strange that this device does not have a battery is empty sign or anything, like actually almost every device on earth has these days. So my suggestion would be to build something in the software (or/and hardware) to warn the user that battery is empty. I mean it can’t be such a magic thing to develop right? :wink:

Another thing that I find really confusing and annoying is the Lid which is required to remove to get to the batteries. mine is already broken, because of trying to open it with a screwdriver that was obviously not broad enough for the slot. it really is a quite stupid design. you only can savely open it, if you have a screwdriver that is exactely the shape of the slot to push off the lid. my lid already looks like scarface, except that the “bent closing handle thing” finally broke last time I tried to remove it… I’d suggest you change this in your next design to just have the lid removed by 4 normal screws (duh!) :wink:

hopefully my criticism helps for future design or firmware upgrade. sorry for being sarcastic. no offense, i like your product and maybe you can’t put in more efforts to improve because of the price or not having enough time because of being pushed to finally release it no matter what, because of management or whatever :slight_smile:

any replies welcome :slight_smile:

all the best

Hi, same problem with batteries full !
Works well for 2 minutes, then reboots again and again, quicker and quicker…