Home x moves in the wrong direction

Hi All,

I’ve just completed assembling the k8200 printer, and went through the 1st checks using the repetier software. So far everything works nicely, except when I press “home X” button, the bed goes towards the left. My expectation is that it goes towards the right, where the stop thingy is located. The wires and the video can be downloaded from:



Any comments?


How far to the left does it go?
If it only goes about 10mm or so and stops then the problem in in the end stop.
You either have an open or the wires are soldered in the wrong position on the switch
The wires go on the outside of the switch.
The firmware thinks the bed has activated the switch.
Also if you are new to 3D printing you should start with this software it is already setup for the K8200.
You will need to make some tweeks but is a good starting place

1 Like


I got a notification that you liked my post.
Is everything working?
I threw a lot of information at you.
Which one of the solutions fixed it?

Hi Wrong_Way,

Thanks a lot for the post. I am really very impressed and thankful for your help.

I am still at the testing stage right now. Up till now I, I downloaded the new software from the URL you provided. Unfortunatlely, I haven’t managed yet to configure it yet. I went through the configuration briefly andjusting one or another parameter there and here (looking at http://www.k8200.eu/manual/printing/?c=002), then I pressed the connect button, the button got green a few seconds later, but the manual control does not work. The window says, that there are commands waiting:

(the old software of course works to the extend that the home x button goes into the wrong direction in steps of 1cm or so, as you correctly also noticed)

The settings of the software are:

In the printer settings “Connection” Reset on connect should be set to “Disabled”
You may want to bump the Receive Cache Size to 127

  • Yes, it goes 10mm and then stops
  • I thought the bed should go rightwards, not leftwards, if I press the home X button? If I use the “old” software then going left moves the bed rightwards (which seems to be what the it is supposed to be), home X moves into the opposite direction
  • Can I just unplug the stopper? Then home X should move in the correct direction until I take it out of the circuit…
  • Cables go into outside ones places
  • this gives me a though: I could connect the stopper from Y axis to test if it is stopper related

“connection reset” setting to “disabled” brought the printer to life. Setting the other value to 127 did not have a lot of impact, but not everything needs to seen immediatelly

Status update: the new software has the same issues as the old software: manual setup <-, -> v, ^ and along the Y axis moves, home Y, home Z works. home X does not work (with plugged and unplugged setting)

status update: the x switcher sucks. I plugged the y switch into the x switch, and did “home x”. The motor moved the bed towards right

this is how the wiring is supposed to be

this is how it is

(the wire does not touch the middle one)

That was the wire, that went to the switcher. Resoldered and home x started moving into the correct direction. @Wrong_Way: good job!

I take it that it is working now.
If you have adjusted the voltage reference for the stepper drivers the manual states to set them to 0.425. you will save yourself a lot of frustration if you set them to 0.55 do not go over 0.6
0.425 will not give the motors enough current to move the bed 0.6 will make the drivers over heat and do crazy things. 0.55 is the sweet spot.

Hi @Wrong_Way,

thanks a lot, the bed is moving correctly.

Thanks for the hint, w.r.t the voltage. At this point they are at 0.42-0.43 range (it is a bit challenge to set it at exactly 0.425), but I’ll take this into consideration.

My key concern is the extruder now. I am trying to print the k8200 cover (as suggested by the manual), but the plastic is simply not going out. If I move the extruder (the big circle), the plastic starts going, but creates a mess (and stops flowing at some point).

Most probably I’ll need to post a new question on that… What do you think?

Check the screw that holds the small gear to the motor.
Make sure it’s tight (don’t strip it) do not tighten the screw (with the spring) for the filament all of the way. You should really adjust the drivers to 0.55mV