Help with the first print with Vertex Nano

Hi, I was able to assemble the Vertex Nano successfully.
The calibration with the delivered GCODE files has also been successful. Through the delivered Vertex Nano Repetier the first ABS product was sliced, after I had added the filament.
The gcode is then put on the SD card and inserted into the printer. After I have selected the file, the Nano starts warming up and positions it above the print bed.
After that, nothing happens!
It looks like the Nano is waiting for something. I have looked at the Gcode and there is nothing special on it, other than the fact that the standard bed temperature is at 55 degrees. Is it possible that the Nano is waiting for a signal (which will never come) that the bed is at temperature?

My first print will have to wait for help from this forum…

Hello !
I do not believe that the NANO has a heated bed … it seems to me that it is necessary to disable (uncheck) the wait for the bed to heat up in the printer profile (Under Ultimaker Cura if you are using it) or specify a temperature of 0 ° C for the bed under the slicing engine that you use under Repetier Host.
Also, are you talking about ABS filament ? … it seems better/easier to use PLA filament to start.

Hi, thanks for the suggestions. Nothing was wrong with the gcode-instructions, There was no indication that there was a heated bed. I noticed that during warming up there was a far too great hysteresis present. This could only indicate a too loose mounting of the thermocouple on the hotend. Despite the fact that it was fixed according to the instructions, I bent the ring a bit so that there would be more pressure on the thermocouple against the hotend. This turned out to be the solution.
Perhaps an addition to the building instruction of the hotend?
To end a long story; the Nano no longer waits endlessly and just starts printing on time.

Thank you very much for thinking along!

1 Like

As @PPAC says, it’s indeed better to start first with PLA printing first, instead of ABS.


Anyway it should also be possible to print with ABS.
However, in original firmware there is an error in firmware, concerning for printing with temperatures above 200°C. Below explained how you can adjust this in the firmware.

"Good alternatives to ABS is, for example, using PLA TOUGH (Alternative to ABS).
Has similar properties, lower printing temperature, and less disturbing toxic substances:

1.75 mm (1/16") TOUGH PLA FILAMENT - GREY - 750 g - Whadda "

Indeed when using Vertex Nano with ABS, the printer keeps waiting because the target temperature cannot be reached. A too small window was set in PID settings in original firmware.

Change number 5 to 20 in line 282 in nano firmware at Configuration.h
of this:

282 #define PID_FUNCTIONAL_RANGE 5 // If the temperature difference between the target temperature and the actual temperature

to this:

282 #define PID_FUNCTIONAL_RANGE 20 // If the temperature difference between the target temperature and the actual temperature

Also change the PID values from this:
// If you are using a pre-configured hotend then you can use one of the value sets by uncommenting it
// Ultimaker
289 #define DEFAULT_Kp 100
290 #define DEFAULT_Ki 6
291 #define DEFAULT_Kd 400

to this:
// If you are using a pre-configured hotend then you can use one of the value sets by uncommenting it
// Ultimaker
#define DEFAULT_Kp 18.99
#define DEFAULT_Ki 1.29
#define DEFAULT_Kd 69.99

Save the changes and upload the firmware again with these changes. Now the nano Printer will correctly reach the ABS temperature (without waiting). and without requiring an adjustment of the printer head (thermocouple).

Furthermore, it is also recommended to fine-tune the PID values ​​of the printer. This can be done with the AUTO-PID command from marlin. More info about this: PID Tuning - RepRap

Enter this G-code command in “manual - control” in Repetier or Cura software.
Printer must be connected to USB.

M303 E0 C8 S210

Then after 8 cycles, get a response back in the terminal.
like this example:

bias: 92 d: 92 min: 196.56 max: 203.75
Ku: 32.59 Tu: 54.92
Classic PID
Kp: 19.56
Ki: 0.71
Kd: 134.26
PID Autotune finished! Place the Kp, Ki and Kd constants in the configuration.h

Save the new PID values ​​with the following g-code command:

M301 P19.56 I0.71 D134.26

Than save the EEPROM settings.

You can also enter these new PID values in the Firmware. Configuratin.h (PID).
Save and upload the firmware.

Best regards,
Velleman Technnical Support

1 Like