Heated bed almost gets to temperateure, then

I have a problem with the heated bed. It does not matter which temperature I put it on, it seems to flatline within half a degree of the temp I need.
For example, if I set it at 65 degrees, it usually gets to 64.7 to 64.8 then flatlines and wont reach 65 for another 15 or 20 minutes.
I tried reducing it to 63 thinking that the bed can get to that heat, but at 63 it flatlines at 62.7.
Same at 55, gets to 54.8 then takes a long time to get there.
I am using that base as is with no glass or mirror plates on it.

It really struggles to get to the correct temp and the temperature curve does the same at almost any heat.

Any ideas?


Just to get a better understanding of your problem,

does it print when it reached the “lowered” temperature or does it wait for the set temp?
What firmware version do you use?

It waits for the set temp to be reached.
The repetier software version is 0.95F. Says its the latest version.
I think the firmware says Marlin V1; sprinter/grbl mashup for gen6
It shows this once I connect the printer in repetier.
Should I upgrade that to V2?

The printer has had no upgrades since I built it.


Maybe try the recent repetier version ans see if that changes the behaviour.

Uploaded and installed the latest Repetier version 1.6.0

It seems to get to the 60 degrees a lot easier than it used to.
It still has the curve but doesn’t flat line just before the set temperature of 60 degrees now.
Now it takes 10 minutes instead of 30 minutes.
Haven’t tried it to 65 degrees, but the Repetier only goes to 70 degrees anyway so now it’s better.
I also like the way it shows the temperature of the bed and the extruder in this latest version!

Thank you!

You’re welcome!

Happy printing!