Firmware Upgrade help

Hello Guys.
I have bought recently a E3d V6 Hotend 12V (but will use it with the stock cartige), a E3d Titan Extruder, and 2 GT2 belts with 18 tooth pulley.
I have the numbers changed in my configuration.h file and did everything what the manual says but If i move my printer in X or Y direction in any program 200 mm but in the real word it only moves 145 mm.
I have changed my numbers from the stock to 64, 85, 88, 95, 100 but in real world the movement stays 145 mm instead of 200 mm.

I ran Arduino 1.0.6, checked my modificated file for any errors, pushed a screw driver into a Jprog switch, I uploaded the firmware, and watched the light flash. When the program said it finished I ran the tests and the same always. What should i Do? Pls help.

Did you load “factory defaults” in repetier after uploading the firmware?
If not, it is likely to use the stored (old) values in EEProm.

You can also change that values directly through repetier’s tool menu, instead of flashing a modified firmware.

Much more convenient, especially for testing.

Hello ichbinsnur!
First of all I am newby at this part of electronics. I have used the basic Firmware what is avalible on the site.
I dont know how to use the stored values in the eeprom, really i have read thing but this side of the electrotechnics is new to me.
Thanks for the Repetier idea. Will it work with the V1.6.2?

I’m using most current repetier version, so yes, it should work.
Only make sure to make the correct settings for com port in repetier host.

Just a quick question. Is there a chance to reverse the rotation somewhere?

Rotation direction for the axes can be inversed in configuration.h

Yes, use your configuration to solve it. Try [color=#333333]to play with[/color] settings