Firmware update for vm8201 problems


I would really appreciate some STEP-by-STEP instructions here.

This is the response i get after connecting the printer in Repetier-Host V0.95F

07:57:09.092 : FIRMWARE_NAME:Marlin V1; Sprinter/grbl mashup for gen6 FIRMWARE_URL: PROTOCOL_VERSION:1.0 MACHINE_TYPE:K8200 EXTRUDER_COUNT:1

even though i have carried out the update firmware procedure to the letter and been informed that uit was successful.

i think the problem is at the final stage of the process where the printer looses the update and reverts to the previous V1

how do i get the printer to save or write the new firmware to the eprom??

I have been using Adruino and as a have already written everything looks successful until after the update is reportedly complete.

please help

i need the update to use the XM8201 stand alone controller - the controller is working okay to heat the extruder and bed - the display and jog dial works as expected bu the unit will not recognize any SD cards inserted.

Did you short the Programming jumper when Flashing?
If not, do so and try again.

If yes, the name string reported is a bit misleading as far as i remember.
Look into the V2 Firmware files. There you should find that string.
I think they just forgot to replace it with correct text.
It’s just a message that’s printed to the serial port.

Anyway, that your display works shows that the update should have been successful.

Your SD problem might have other reasons.

Did you try different cards?

so, If the update has been successful - would the firmware message on repetier not tell me i am using firmware version XXX?

The version reported will still be v1


thank you - what size card should i use? just a simple FAT format (not fat32 , efat or ntfs etc.)?

if i have the size and format right, and i select init sd card on the controller menu - what response should i get - do i see something other than no card on the menu

tried 5 different SD cards 512mb, 1gb, 2gb, 2 X 4gb and a 16gb

all get the same no card message with a reset betwween

is there ANY way i can confirm what firmware version IS installed on the board?

if V1 is the only response i should expect - then how will i ever know when an firmware update has been successful??

Well, if your display works the upgrade was successful, as the V1 doesn’t support the display.
I currently don’t have a display so i can’t help you vermy much with it, but i will try as good as i can.

I think the card size should be max 16gb.
I don’t know if the display board supports XD cards.

Plat FAT should work.
Probably Fat32 too, but i’m not absolutely sure about that.

i assume my unit must have come with v 2 or v2.1 installed then, because the display on the controller has worked from the start, before i even discovered i needed a firmware update, BUT if that is the case then the controller is completely useless without a functioning sd card reader - i am sure that it is not a CARD issue - i have used them in other “FAT ONLY” devices and they all work fine and have received a FULL FORMAT(not quick) using a specific sd card formatting utility and regular windows os format

what can i do to confirm any of this?

if i cant verify any of my assumptions then i am wandering in the dark

fixed the recognition problem by re-souldering all of the pins into the board - there must have been a bad contact(but none visible) so i now get the print from sd option on the menu - now the only problem is that i can’t move up and down on the menu using the scroll wheel only the press works any suggestions most appreciated

Just wondering if you printed the knob and mounted it.
If so did you press to hard to get it on?
Maybe you loosened one or more of the solder connections to the encoder?
You may want to look at them with a magnifying glass.