Firmware Flashing breaks machine

I have downloaded the firmware from the official website and wanted to upload it to my 3dprinter as a test, because I then wanted to play around with a few settings in the firmware. But after uploading the UNMODIFIED firmware, the printer is broken. It cannot home anymore.

Also, it only tries to home the Y axis and only tries about 15mm. Then it stops. If it hits the end-switch, it tries to go further. it does not think the endstop is clicked.

What should I do?

Kind Regards,


I have flashed the machine again. now it recognizes the endstops when i use the menu to move x/y/z axis. But when I click home, the motor clicks once, and then the firmware resets.

We can’t recreate your problem.
What Arduino version are you using? Did it word before you changed the firmware? Are you sure all cables are still connected?
Could you send us a video?

Yes, the Printer worked before. I have printed some things. (I will try to show them in the video.)

I downloaded and flashed the zip from this page: … downloads/

I flashed it with the Arduino IDE version 1.8.0.

I am making a video now.

EDIT2: Here is a playlist with all the videos: … XeXNw3WjM-

Here is one video where I show the flashing (no audio):

and here is the video of the behaviour I described in the first post. Homing only moves the Y axis and only moves about 10 mm and then stops, if it did not hit the endswitch. If it DOES hit the endswitch, it tries to go further and crashes the head into the endswitch and you can hear the motor skipping steps. I then turned off the machine.

Sorry for the bad audio.

What I didn’t film: If you move the axis with the Control Printer -> Move Axis menu, it will stop at the endstops and not go further. so the motors and the endstops work as intended, but not during home.
EDIT: I made another small video ( to show the endstops working. Because I don’t have a tripod, I didn’t show the Y axis, but it behaves EXACTLY the same. So does the Z axis. The endstops are properly installed and working.

I don’t know about the K8600
However the K8200 and the K8400 you had to use Arduino version 1.0.6 or lower.
You can download it from this link.

I will try this. But the Firmware flashing process seems to work fine.

We’ll see. Thanks for the tip.

that clears that up quickly:

In file included from MarlinConfig.h:39, from Marlin.h:36, from watchdog.cpp:23: SanityCheck.h:34:4: error: #error "Versions of Arduino IDE prior to 1.6.0 are no longer supported, please update your toolkit." In file included from Marlin.h:58, from watchdog.cpp:23: printcounter.h:54: error: ISO C++ forbids initialization of member ‘address’ printcounter.h:54: error: making ‘address’ static printcounter.h:64: error: ISO C++ forbids initialization of member ‘updateInterval’ printcounter.h:64: error: making ‘updateInterval’ static printcounter.h:72: error: ISO C++ forbids initialization of member ‘saveInterval’ printcounter.h:72: error: making ‘saveInterval’ static printcounter.h:86: error: ISO C++ forbids initialization of member ‘loaded’ printcounter.h:86: error: making ‘loaded’ static printcounter.h:86: error: ISO C++ forbids in-class initialization of non-const static member ‘loaded’

Yes that’s correct

The firmware needs Arduino 1.6.0 or Higher

[quote=“VEL337”]Yes that’s correct

The firmware needs Arduino 1.6.0 or Higher[/quote]

Could you also review the videos?

My printer is still not working. Could you please review the videos and suggest what I should do?

Thank you.


I also want to play with the firmware, but i see this thread just stopped without a result.
So i am curious to know did you ever solve the problem???


Anybody still alive around here, or should nobody bother to come here?