Faulty Heater Bed

I have just completed the K8200 and everything seems to work but the heater bed! When I switch it on the graph starts off at room temperature then the graph just goes crazy and shoots up and down showing temperatures up to 130 degrees then back down in seconds! I have tried it again and the graph starts of as a straight line then shows the temp rising up to 50 degrees as it should then stabilising and when I switched the bed of it started to cool then the graph just went haywire again! I have photos of the graph and any help would be really gratefully received as I am stuck! Thanks in anticipation.

This behavior looks like a bad contact. Check the plug for bent contact(s) and/or the wiring of the CTN.

Thanks for your help regarding this matter. I will disconnect the pair of cables that connect the thermistor to the circuit board and connect a separate pair direct from the heater bed direct to the circuit board. This will either identify a faulty cable/ and/ or faulty connection or rule out the wiring as a problem.

Tried bypassing existing wiring with new pair from thermistor to board but just the same result. I have reconnected as original and the graph shows a room temperature of 10 degrees then nothing and then back up to 10 degrees. When I press the heat bed button the heater bed heats up and I have measured it at over 50 degrees but as the programme is only showing it at around 14 degrees I thought it might not cut it off so I switched it off. Is there a way of inserting a picture of what’s happening which may explain it a lot better. I have taken a copy of the graph using the snipping tool and could forward as a png or jpeg if that would help as after several hours of getting nowhere it is a bit frustrating as a first project the only item that doesn’t work is a simple heater bed!! Once again any help would be gratefully appreciated.