Extruder troubles: Filament feeder keeps jumping back

I got myself a Vertex Delta K8800 a few weeks ago, and after assembling and calibrating the printer it worked just fine. But after some prints that came out like expected, I encountered issues with the bowden extruder. It works just fine for a while and then suddenly starts pulling back the filament randomly, which results in a poor printing due to a lack of material. When doing so, it does not sound and look like “normal” stepper motor operation. It’s more like the motor is jumping backwards about eight or ten degrees, pulling back the filament. This produces a loud and harsh noise. This repeats a few times, then the extruder returns to normal operation for a while until it all starts over again.
I examined the stepper motor which seems to be flawless. I also eyeballed the controller PCB, which also seems to be fine. Same applies to cables, connectors and solder joints. Finally, I checked the extruder motor’s trimmer alignment as described in another thread. I measured the voltage which is supposed to be 1,05V, and it’s spot on.

I urgently need the otherwise great printer to work again, so I appreciate every assistance. Thanks!

Greetings from Germany

1 Like


Have you tried to print the first projects again using the same gcode?
Just trying to figure out if this is a printer problem or a slicer issue.

thanks for your answer. The slicer (corrupt gcode, that is) was my first suspect. So I reprinted a known good project using gcode that was still on my SD card. This time, it failed.
I also tried to figure out wether or not the motor was exhibiting any temperature sensitivity. But heating it up to it’s temp limits didn’t make it fail more (or less) often.

This is huge guess but maybe something to test.

It would have been great if that was the cause. So easy to fix. But unfortunately, it isn’t. The printer does not try to unload the filament. Also, the LED attached to the filament detection does not light up at any time.
It’s a sudden movement in reverse direction. It’s definitely not normal motor operation. My guess is that the motor misses some of the electrical pulses. But I can’t figure out who’s the culprit. It could be the motor, the cable, the connectors or the motor driver on the main PCB.

Seems to be complicated. Maybe a Velleman technician has an idea. That’s what I’m hoping for now…

Unfortunately I’m out of ideas.
Could you post a video of it?
That might help a little.

You could also open a trouble ticket in this link.

I’m going to try to catch it on video. It’s an intermittent failure. Considering Murphy’s law, what are the odds to succeed? :wink:
I’ll wait until tomorrow, maybe a Velleman technician replies by then. Maybe I have to open a ticket.

Thank you very much for your help.

One last thought.
Check the cable that plugs into the motor.
Maybe it’s not seated all of the way.
Maybe unplug it and re-plug it

Hi Maddin,

This was a problem with some of the printers of the very first batch production run. It could be you have one of these printers. We have identified this problem and fixed it going forward. The fix for this is giving the stepper motor a little extra current. This can be done by adjusting a trimmer next to the stepper driver on the main board of the printer. for this however you will need to get to the bottom of the mainboard (dissasemble some parts) and know how to use a multimeter.

If you are keen on trying it yourself I can send you a guide on how to do this. If however you are not interested on doing this yourself you can create a ticket here: https://support.velleman.eu/ 1 and note the problem and also add that a Velleman technician has told you that “a change in extruder stepper driver current” is needed. You will need to send your mainboard or printer to us so we can make the correction.

If this is not the problem, it can also be you have a partially clogged printhead or the plastic parts on the extruder block are not mounted correctly. Both are easy to check by dissasembling these parts and checking them.



as I wrote in my initial post, I already disassemled the printer, popped out the mainboard and measured the voltage as described here: https://imgur.com/a/8zi6YGy
It’s exactly 1,05V. So the motor current should be correct, right?
I also disassembled the extruder’s cold end, checked it and put it together again. It was (and is) flawless.
The printer’s nozzle is not clogged, I checked that as well.

Please send me the guide you mentioned, I think I can fix it myself then - provided it’s really a matter of adjustment and not about a faulty part.

Thank you.

[edit: typo]

Hello there,
i own a K8400 and i have the same problem. I adjusted the voltage like 10 times now, but the stepper keeps falling back.
The printer is about 2 years old, but i never really got it to work properly. I have a broken leg atm so i have a lot of time.

Could you please send me a guide on the K8400?

I would really appreciate it so i can print out the parts i need for the E3D head.

Thanks in advance

Maybe I’m late but I’ll contribute anyway in case this info will help somebody.

This issue is the result of the stepper motor not being able to force the filament into the bowden tube and the nozzle. This can arise in a couple of ways, one is that the motor driver has its current set too low and the motor does not produce enough torque or the torque that the motor produces is not transferred to the filament well because the wheel is slipping.

You can try and guess what is happening by observing the extruder wheel while the filament is backing up, if the wheel reverses too the motor failed to hold or push the filament or if the wheel stays put it means it lost its grip on the plastic.

In the first case You can try to increase the drivers current but chances are that if the issue just appeared suddenly there is something wrong in the filament path or the nozzle is too cold. Try to remove the bowden tube and feed the filament youself into the heated hotend, it should not require too much force and you shoud feel the filament “disappearing” inside.
Try the same with the bowden attached to the hotend but not the extruder, it might be a little harder to push but not too much, again you should feel the filament move under force.

When inserting new filament make sure the end is cut at an angle so that it will slip in nicely not getting caught inside the extruder assembly or the hotend (I found there is a slight ridge where the PTFE tube meets the metal inside the hotend and sometimes it was hard to convince the filament to skip past it when the end was not cleanly cut). In case it’s not easy to feed the filament manually either the temperature is too low (I once inserted PETG and was convinced it was PLA, PETG will not flow nicely @ 200°C) or there is an obstruction of some sort, in that case it might be neccessary to clean the nozzle which is not too hard but I won’t go into the detail here as it can be easy to find this info online.


Hi riodoro1,

thanks for answering. Meanwhile, I have fixed the printer (the feeder and a few other flaws) and it’s working fine now.
You are right, the issue is caused by insufficient motor torque or too much sliding friction on the way to the nozzle respectively.
First thing I tried was increasing the motor current and hence its torque. That helped a little, but after 20 minutes of printing, the motor driver got too hot and its thermal protection kicked in, limiting the current. The problem was worse than before.
I then took a closer look at the cold end. The motor shaft was quite hot and so was the wheel attached to it. Friction between the feeder wheel and the filament was significantly reduced by the heat. I disassembled the cold end and found the filament path to be roughened by the filament. The cold end is very liable to wear.

Solution: I replaced the original plastic cold end by a metal one and glued heatsinks (thermal glue needed!) to the motor driver ICs. I also replaced the crappy and loud cooling fan by a better one.

That did the trick.

1 Like

Just wondering
Did you check the screw that goes into the lever?
Is it to tight?

I checked that screw more than once. It was just as tight as it was expected to be. With the screw too tight, I never would have experienced the torque issue. The filament would just have slipped.
Compared to my new feeder unit’s driver gear, the original one has far less sharp teeth. I’m afraid to say that the original feeder unit is of rather poor quality. I’m glad I swapped it.

Please, can anybody send me the guide about the extra current for the stepper motor?
I see the same problem - mostly when printing the brim…

@VEL327, wouldn’t it make sense to pin that document into the FAQ section?

I already posted a link to the guide in this thread, here it is once more: https://imgur.com/a/8zi6YGy
Additional info: The current is indirectly adjusted via a corresponding voltage. You may want to download the printer’s schematics as well as the stepper driver’s datasheet to figure out how current and voltage correspond. As far as I remember, in this config increasing the preset voltage by 50mV will result in additional 100mA of motor current. NOTE: I can be wrong here, check for yourself!

So I got you wrong because you asked support after posting your link…
Anyhow - if it’s sufficient to change the voltage to 1.05V I will try that one…

1.05V ist the default value. If you want to increase it slightly, try 1.10V.
By the way: Issues with the brim (and poor printing in general) can be caused by a inappropriate retraction setting. You may want to check the retraction value is right by printing the test objects you can find on thingiverse. I got mine set to 2.5mm.