Extremey Dissapointed with my Nano

I got my Nano for Christmas. But it is more of a nightmare then it is fun :frowning: .
First I am quite surprised that a Belgian company does not even has a manual in their native language.
Secondly the sites with manuals have been down several times.
Following it is a printer advertised for kids and starters (where it was bought). I laugh at this. No kid can assemble this on his own and for starters this is not a happy start.
Since i have a Mac and not a Windows, a specific question upon buying was if that would be a problem. Of course not, was the reply. Too bad the manual only makes references for programs to use in Windows. No reference to a program to use with Mac. Big Fail!
Since the kit has been assembled, i have had nothing but trouble and problems…
Every single problem you can imagine, i have experienced it.

  • the Z will almost never calibrate correctly. not with the gcode, not manually
    in the event it does happen to be correct, another part of the printer malfunctions.
  • The nozzle has been blocked several times.
    ° The entry of the extruder cooler scraps the PLA, which causes blockage.
    ° PLA keeps on dripping from the nozzle, whenever the printer is on.
  • The extruder has been blocked several times.
    ° Screws are too tight or too loose
    ° Coil spring was too long (impossible to handle the extruder to load PLA)
  • The teflon tube has been blocked.
  • By attempting to print something, steps are skipped.
  • The leadscrew grins out the screw nuts. This causes them to loose their functions and they ‘leave’ the Y side axis holder when it moves. I have already replaced 4 M4 screws (both inox and iron) in 4 days…
  • The fan against the extruder body does not work properly.
  • The printer can start to move on its own and then crashes onto the bed.

I also tried calling the company in Gavere, but it seems the lady aswering the phone is not interested in helping out customers with problems…

Anyone here has some thoughts on what could be the problem(s)?

Oh, quite a bad one it seems. :-/

Sadly, this forum isnt too lively. I haven’t found a suitable forum actually :-/ (please tell if you find any active hangout!)

I were luckier and got decent prints right away (I got the printer asembled). Still feel like adjusting and fixing stuff…

Hi @Tellytjen,

Sorry to hear you are disappointed with your Nano. Our colleagues from customer support told us they are trying to resolve your issues via our customer care ticket system.

Some feedback for everyone:

  • Manuals are available in English, Dutch, French, German, Spanish, Polish and Portuguese on our manual platform https://manuals.velleman.eu/ (use the language selector box in the top menu to change the language).
  • The Nano is available as a assembled module (VM8600) and kit version (K8600). The kit version is an advanced building set, we will update our product info sheets reflecting this.
  • We recommend Cura as slicing software. It is available on Windows, Mac and Linux. After installing Cura, please select the Vertex Nano as your printer. All our filaments are also available in Cura.
  • When describing your problems on this forum, please add as much pictures as possible. This makes it easier for us to determine your problem and help you.

Kind regards,

Some of the problems/bugs you mention has been solved in later Marlin firmware. you can see this post for my contribution to this: Updated firmware - Marlin 2.0.x
Take note on my post there about the Z calibration.

Then there are some mechanical issues I’d suspect. My suggestion on this is:
Make sure the guide rails are perfectly parallel. Even the slightest deviation will cause the axis to jam, and cause the stepper motor to skip steps. The brass bushings need proper lubrication, lack of that will cause jams.
About the leadscrew: The stepper driving this leadscrew need to be “loose” to allow some playroom. The leadscrew itself need lots of lubrication. A too-tight stepper motor will cause too much wear and tear on the nuts as it has no playroom for tolerances.

The other issues I don’t know too much about. Sounds more like a heavy usage wear and tear.
Used my own Vertex Nano for a few days and a bunch of failed and successful prints (mostly successful) and the machine still plays nice. I don’t have any more trouble than I do with the Ultimaker 2+. The usual stuff.

For the software part, I recommend Cura: https://ultimaker.com/software/ultimaker-cura
It has support for lots of 3D printers, including the K8600 / VM8600 Vertex Nano.
It has a Mac version, as well as Linux and Windows.

A short comment to Ultimaker Cura:
The original maschine settings in Cura for the K8600 / VM8600 Vertex Nano are wrong. The printer don’t work with it. The gcode for start and end must changed.
Please read the post: https://forum.vellemanprojects.eu/t/probleem-bij-eerste-gebruikname/32443/22