Echo: too long extrusion prevented


I have following problem:
The Printer worked fine until these morning. While printing (at the beginning, when the printer makes the 3 “rounds oround the object”, the bed moved a few cm left (in X), moved back and made nothing since them.
Then I tried to move the Axis now via G-Code and I become the folowing Request:

17:02:11.987 : N24 G1 Z1 F100 *34
17:02:12.003 : ok
17:02:12.003 : echo: too long extrusion prevented

Fan, heaters etc. i can turn on and off, and they are working. The LEDs will go on then on the board.
When I want to make a movement on X, Y, Z or extruder I ill only receive the message: “echo: too long extrusion prevented”
No LEDs near the Motor-Driver is going on (but I have also never seen them before, when the printer was working…)

The temperatures are all OK:
21:35:44.953 : ok T:69.8 /200.0 B:30.7 /55.0 @:127
(I just turned the heaters on.)

The Firmware:

Before the error I did no changing in the software (Repetier)or in the sliz3r. After I tried to make a newfirmware to the board (original from The firmware-transfer was OK, but the same error is still there.

I testet the same with an other PC, that was working with the pinter a few days ago - with the same error-mesage from the board.

What can I do ? Can I flash the board before installing a new firmware (with arduino) ?

Thanks for your help

Hi, Is it possible to post the gcode file? I would like to test it inhouse and see if I can find the solution to the problem you are having.

Thanks für your reply.

I have no gcode file genereted. The Problem is also bevor you run the file, when I use to control the printer manually or by manual gcode-inputs.
When I run a dcode-file, the echo-message is the same like by the manual input.

  • I connect the printer (echo: firmware etc…, connection is OK)
  • I give manually a gcode or push on the button to move Z+ or another axis
  • N24 G1 Z1 F100
  • ok
  • echo: too long extrusion prevented

For me it looks like an firmware or board-error. Is it possible to load a “modificated” firmware for testing ?
Do you need any gcode file yet ?

You can try to flash your board to the V2 version of the firmware. See the latest chapter in the how to use to printer manual to learn how to flash your board.


now I flashed the firmware V2 on the board.
The same error (no moving the axes) but now without the error-message:

20:33:32.874 : N104 G91 *52
20:33:32.875 : N105 G1 Z0.1 F100 *14
20:33:32.877 : N106 G90 *55
20:33:32.885 : ok
20:33:32.885 : ok
20:33:32.885 : ok


20:35:34.729 : N107 G28 Z0 *127
20:35:34.734 : ok

nothing moves.

The heater and the fan can be switched on/of and they do it like before, in V1.

Then I flased back again to firmware V1:

20:40:56.187 : ok
20:40:56.187 : ok
20:40:56.187 : ok
20:40:56.187 : ok
20:40:56.187 : ok
20:40:56.188 : N7 M111 S6 *64
20:40:56.194 : N8 M80 *51
20:40:56.206 : ok
20:40:56.206 : ok
20:42:57.017 : N9 G28 Z0 *112
20:42:57.035 : echo: too long extrusion prevented
20:42:57.035 : echo: too long extrusion prevented
20:42:57.035 : echo: too long extrusion prevented
20:42:57.035 : ok

Nothing. LED for USB is flashing, LEDs on the drivers stay dark.
Hm… What can I do now ?

No movement on V2 when you press the home button?

No movement when I press home.

I have exactly the same problem like “Sunder”. After I had anew adjusted last night the printer table this mistake was there suddenly. I have often enough adjusted the printer table and there was no problem. I have changed nothing in the firmware and I have changed nothing in Repetier-Host. The mistake must have another cause. Maybe the Board is defective. But why?

From what I’ve read on the net it can happen when your trying to move outside the bed boundaries (eg you define your bed as 100x100 in the configuration file and try to move it to the 150x150 position).

Hmmm, I checked the printer on different computers, also one, wich run a few dasy before. No moving.
And: Is there any gcode given to the printer, which definates the bed-size, before I run a programm ?
When there is something given to the printer, than it is possible. The graph in repetier is with a line outside the bed, but i vever changed something.
I dont know, how I can chnange this, in because I never changedt this before and the other repetier-inatallation on anothher PC is the same “error”.

Check in the printer settings under “Printer Shape”
Make sure the Width, Depth and Height are all set to 200

Everything is 200.

Now I testet:

start repetier, no blue line is shown

21:03:18.104 : OpenGL version:4.0.0 - Build
21:03:18.108 : OpenGL extensions:GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_blend_color GL_EXT_abgr GL_EXT_texture3D GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_SGIS_texture_edge_clamp GL_SGIS_generate_mipmap GL_EXT_draw_range_elements GL_SGIS_texture_lod GL_EXT_rescale_normal GL_EXT_packed_pixels GL_EXT_texture_edge_clamp GL_EXT_separate_specular_color GL_ARB_multitexture GL_ARB_map_buffer_alignment GL_ARB_conservative_depth GL_EXT_texture_env_combine GL_EXT_bgra GL_EXT_blend_func_separate GL_EXT_secondary_color GL_EXT_fog_coord GL_EXT_texture_env_add GL_ARB_texture_cube_map GL_ARB_transpose_matrix GL_ARB_internalformat_query GL_ARB_internalformat_query2 GL_ARB_texture_env_add GL_IBM_texture_mirrored_repeat GL_EXT_multi_draw_arrays GL_SUN_multi_draw_arrays GL_NV_blend_square GL_ARB_texture_compression GL_3DFX_texture_compression_FXT1 GL_EXT_texture_filter_anisotropic GL_ARB_texture_border_clamp GL_ARB_point_parameters GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_env_crossbar GL_EXT_texture_compression_s3tc GL_ARB_shadow GL_ARB_window_pos GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_ARB_vertex_program GL_EXT_texture_rectangle GL_ARB_fragment_program GL_EXT_stencil_two_side GL_ATI_separate_stencil GL_ARB_vertex_buffer_object GL_EXT_texture_lod_bias GL_ARB_occlusion_query GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_non_power_of_two GL_ARB_vertex_shader GL_NV_texgen_reflection GL_ARB_point_sprite GL_ARB_fragment_program_shadow GL_EXT_blend_equation_separate GL_ARB_depth_texture GL_ARB_texture_rectangle GL_ARB_draw_buffers GL_ARB_color_buffer_float GL_ARB_half_float_pixel GL_ARB_texture_float GL_ARB_pixel_buffer_object GL_EXT_framebuffer_object GL_ARB_draw_instanced GL_ARB_half_float_vertex GL_ARB_occlusion_query2 GL_EXT_draw_buffers2 GL_WIN_swap_hint GL_EXT_texture_sRGB GL_ARB_multisample GL_EXT_packed_float GL_EXT_texture_shared_exponent GL_ARB_texture_rg GL_ARB_texture_compression_rgtc GL_NV_conditional_render GL_ARB_texture_swizzle GL_EXT_texture_swizzle GL_ARB_texture_gather GL_ARB_sync GL_ARB_framebuffer_sRGB GL_EXT_packed_depth_stencil GL_ARB_depth_buffer_float GL_EXT_transform_feedback GL_ARB_transform_feedback2 GL_ARB_draw_indirect GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_ARB_framebuffer_object GL_EXT_texture_array GL_EXT_texture_integer GL_ARB_map_buffer_range GL_ARB_texture_buffer_range GL_EXT_texture_snorm GL_ARB_blend_func_extended GL_INTEL_performance_queries GL_ARB_copy_buffer GL_ARB_sampler_objects GL_NV_primitive_restart GL_ARB_seamless_cube_map GL_ARB_uniform_buffer_object GL_ARB_depth_clamp GL_ARB_vertex_array_bgra GL_ARB_shader_bit_encoding GL_ARB_draw_buffers_blend GL_ARB_geometry_shader4 GL_EXT_geometry_shader4 GL_ARB_texture_query_lod GL_ARB_explicit_attrib_location GL_ARB_draw_elements_base_vertex GL_ARB_instanced_arrays GL_ARB_base_instance GL_ARB_fragment_coord_conventions GL_EXT_gpu_program_parameters GL_ARB_texture_buffer_object_rgb32 GL_ARB_compatibility GL_ARB_texture_rgb10_a2ui GL_ARB_texture_multisample GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_timer_query GL_ARB_tessellation_shader GL_ARB_vertex_array_object GL_ARB_provoking_vertex GL_ARB_sample_shading GL_ARB_texture_cube_map_array GL_EXT_gpu_shader4 GL_ARB_gpu_shader5 GL_ARB_gpu_shader_fp64 GL_ARB_shader_subroutine GL_ARB_transform_feedback3 GL_ARB_get_program_binary GL_ARB_separate_shader_objects GL_ARB_shader_precision GL_ARB_vertex_attrib_64bit GL_ARB_viewport_array GL_ARB_transform_feedback_instanced GL_ARB_compressed_texture_pixel_storage GL_ARB_shader_atomic_counters GL_ARB_shading_language_packing GL_ARB_shading_language_420pack GL_ARB_texture_storage GL_EXT_texture_storage GL_ARB_multi_draw_indirect GL_ARB_program_interface_query GL_ARB_debug_output GL_KHR_debug GL_ARB_arrays_of_arrays GL_INTEL_map_texture GL_ARB_texture_compression_bptc GL_ARB_ES2_compatibility GL_ARB_robustness GL_EXT_texture_sRGB_decode
21:03:18.108 : OpenGL renderer:Intel® HD Graphics 4000
21:03:18.108 : Using fast VBOs for rendering is possible
21:03:22.788 : Serieller Verbindungsfehler:System.IO.Ports.SerialErrorReceivedEventArgs
21:03:34.128 : Error:Printer stopped due to errors. Fix the error and use M999 to restart!. (Temperature is reset. Set it before restarting)
21:03:34.281 : N1 M110 *2
21:03:34.282 : N1 M110 *2
21:03:34.283 : N2 M115 *4
21:03:34.283 : N3 M111 S6 *68
21:03:36.639 : start
21:03:36.639 : echo: Brown out Reset
21:03:36.640 : Marlin 1.0.0
21:03:36.640 : echo: Last Updated: 2013-03-08 | Author: VELLEMAN - GELOEN
21:03:36.640 : N1 M111 S6 *70
21:03:36.640 : echo: Free Memory: 5528 PlannerBufferBytes: 1232
21:03:36.640 : echo:Stored settings retreived:
21:03:36.641 : N2 M80 *57
21:03:36.666 : N3 M80 *56
21:03:36.666 : N1 M110 *2
21:03:36.880 : ok
21:03:36.880 : ok
21:03:36.880 : ok
21:03:36.880 : ok
21:03:36.881 : N1 M110 *2
21:03:36.881 : N2 M115 *4
21:03:36.882 : N3 M111 S6 *68
21:03:36.882 : N4 M111 S6 *67
21:03:36.906 : ok
21:03:36.910 : N5 M80 *62
21:03:36.925 : ok
21:03:36.925 : ok
21:03:36.925 : ok
21:03:36.925 : ok
21:03:36.925 : N6 M220 S100 *71
21:03:36.926 : N7 M221 S100 *71
21:03:36.926 : N8 M111 S6 *79
21:03:36.938 : ok
21:03:36.938 : ok
21:03:36.938 : ok
21:03:37.113 : N1 M110 *2
21:03:37.114 : N1 M110 *2
21:03:37.114 : N2 M115 *4
21:03:37.115 : N3 M111 S6 *68
21:03:37.138 : ok
21:03:37.139 : ok
21:03:37.139 : N4 M111 S6 *67
21:03:37.162 : ok
21:03:37.163 : ok
21:03:37.163 : N5 M220 S100 *68
21:03:37.163 : ok
21:03:37.163 : N6 M221 S100 *70
21:03:37.170 : ok
21:03:37.170 : ok
21:03:37.177 : N7 M80 *60
21:03:37.177 : N8 M111 S6 *79
21:03:37.186 : ok
21:03:37.186 : ok

Then I give a gcode

21:05:38.569 : N9 G91 *56
21:05:38.580 : ok
21:05:38.596 : N10 G1 Z1 F150 *32
21:05:38.597 : N11 G90 *0
21:05:38.612 : ok
21:05:38.612 : echo: too long extrusion prevented
21:05:38.612 : ok

And the line is in on the screen like my last
The printer-settings you can see at
Is this blue line usual ?

Hi Sunder,

First: My K8200 works again.

Yesterday I have tried a lot. All the errors that you have described here in the Forum, were just at my K8200.

After under configuration (Config) in the menu the item ‘firmware EEPROM configuration’ I was launched and there loaded the factory setting, does the printer again, although NOT!!! the factory setting in the EEPROM, I saved.

I know not why, but after that there was no error messages. My printer works again.

Maybe (and I it hopes) this helps you…

Greetings from Munich

Hello Snuko,

Thanks thanks thanks :slight_smile:
The EEPROM factory-Reset in repetier was the solution… I wounder, that the same error came on 3 PCs. But the printer is working now.

Greetings from the north of germany to munich. Next time, I m in munich I have to invite you to a beer :-). Thanks.

hmm you have this error:

echo: Brown out Reset

usually this indicates a faulty power supply…