Delta Large Diameter Prints Fail

My K8800 prints pretty reliably anything smaller than 150mm in extent. Now I am try to print a flat board (prototype of a PCB), about 1.6 mm thick, on top of a raft. The extents are large but still within the maximum (183 x 88.5 x 1.6mm). The part is sliced using Cura 4.9.1. The same part divided into two halves prints fine, although with an odd scrape at one point.
When I try to print the full part, it gets to a certain point in the build, then the printer pulls itself to pieces. It seems that the print head catches on the part, and although normally it would recover from that, because it is at its maximum extent, it pulls the magnets apart.
I have tried:

  • tightening the belts
  • tightening the rods (then loosening very slightly)
  • relubricating the rods (two drops only)
  • checking the magnets
  • switching to Marlin 2.0.x firmware (which did help some)
    Still no print.
    Can anyone help here please?

I don’t have a K8800 but a K8400 so on the mechanical assembly side I don’t know.
But question setting of cura 4.9.1 did you use a retraction and a Z Hop on layer change ?
What is your flow? 100% ?
And what do you have as infill? 20% ?
Because if you have a slight over-extrusion, it creates extra thicknesses and it hinders the displacement of the head. So you may have to reduce the flow …
Maybe it is also necessary to check the calibration of the extruder (M503 and M92 Set Axis Steps-per-unit | Marlin Firmware to adjuste the Esteps/mm to get 10 mm of filament from the extruder when ask to get 10mm …)?
And maybe you also have to check the speed of movement.

Can you share your cura settings in html ?

And your actual M503 result ?

Also I’m not a raft fan, I use the brim to avoid warping. If you have a plate adhesion problem, you must review your cleaning method and plate/nozzel distance/calibration and parametres (flow rate, temperature, printing speed, …) for your initial layer. But can be a totaly diffrent storie with a delta …

Thanks for all your help - I will try your suggestions when I get a chance.
The raft is needed because the print has a lot of very small holes that get printed early on as small rings - on their own they do not adhere well. Also a brim would take the print even closer to the limits. I already cut travel speed in half and limited accel and jerk. this helped.
I calibrated the E steps, using the measure-extrude-measure method - interestingly, the result exactly matched the updated value @SusisStrolch already put in the updated 2.0.7 firmware.