Connectivity Issues

Hello, i am having some problems connecting Repetier Host with the board. The error message is as follows:


This is my settings,

My previous USB is spoilt, so I soldered on an Arduino typed USB to the board instead. (USB type B)
Both lights are lighted up ( Red and Yellow )

I have also downloaded the required USB drivers from, VCP Drivers - FTDI .


From what I read in the manual, It is supposed to be connected to COM7 instead of COM5, how do I go about doing so?

Any help will be greatly appreciated?

Hello !

Thanks @Wrong_Way

“ASCII” as transfert protocol !

Make sure you are using the correct COM port you see in Windows Device Manager when plugging in the USB

And, if you have Repetier Server installed, stop it, or it will automatically connect and keep the COM port busy.

Otherwise from time to time you have to restart Windows if the COM port is ‘busy’ when there is no application using it.

Hello, I have tried changing to ASCII , but it still not working. I have updated the post, hope it makes the problem clearer! :slight_smile:

For the port number this may change depending on the configuration or also depending on the USB port of the PC to which you connect (does not matter the number as long as you used in repetier the one you find in the device manager when you plug in the usb between the PC and the printer card)

“Both lights are lighted up (Red and Yellow)”

this is a good sign, because without the power supply, when you plug the USB they should light up. (so +5V and GND are correctly soldered.) but in principle, if you also connect the sector they must switch off. And they should flashed during a data transfer.

So it may be necessary to check the wires, solders and tracks where DATA+ and DATA- are soldered (have you done a continuity check ?)

Or maybe try another USB cable ?