Component tester kit K8115

I assembled the kit but the display does not show data when the button is pressed twice while calibrating and all probes connected to each other. It only lights up for a few seconds and then goes out again.
Is there a way to test the display to find out whether it has been soldered correctly?
or

1 Like

Update: VR3 pin 1 should give 3V3 but I measure 4V39. Anyone had the same problem?
Is VR3 defective? Did the overvoltage blow my LCD?

Hello,

First we have answerd this topic on Your posted Customer Care Ticket. and topic above.
And today we have sended the requested parts to You by post.

When you receive the parts, first to do is replace the IC1 4050.
In the most cases this will solve the problem of no text on LCD.

Due wrong delivered batch of CD4050. Our apologies.

Best regards,
Velleman Support

Hello guys,
my feeling is, that I have the same problem.
After assembling all parts I did the first test - if fails - only the background light of the display was on.
After about 25 seconds the display got off, however turned on again by pressing the button.
Again after about 25 seconds the display got off. (see attachment)
So I checked the soldering and parts - everything ok.
Next I checked the voltage - however without LCD PCB.
The output of VR3 had 4.4V while the input was about 5V - originally it should be 3.3V
Based on information of the forum


I removed IC1 (CD4050) - in this case the output of VR3 had 3.3V.
So I assume that I probably have also a problem with wrong or damaged CD4050.
Based on the information of this forum I opened a ticket, however they closed the issue
explaining, that I should search for help in this forum.
It seems that the Velleman product support dont’t care about customer issues.
How should I proceed now?
Any suggestions?

I reopened the ticket and requested a new IC1 and VR3. Copied the solved forum item which had the same problem. They’ve sent me a new IC1 and VR3.
I replaced de IC1 but still the same problem. I did not get to check the VR3 yet.

Hello, yes, my unit, from Riedl Electronic, Graz, Austria, seems to have the same problem.
Only Backlight, nothing displayed.
I checked everything about 200 times, could not find any assembling failure.

In the meanwhile I got CD4050 and VKVPA020.
Many thanks to the customer support.
However when replacing CD4050 - nothing changed - exact the same behaviour.
The I got back to my own CD4050 and replaced the processor (ATMEGA328P) with the new one (dsPIC33FJ32GP) the behaviour is different. When pressing the button the backlight goes on, resuming the button the backlight goes off. I have no knowledge about the controller.
Changing both CD4050 and processor with the two new items I have the same behaviour.
So it seems the replacing CD4050 makes no change in behaviour.
Replacing the processor doesn’t make it better.
The display still doesn’t work (except the backlight).

How can I check the LCD board?
What type of LCD is used - is there any datasheet?

I found in a different forum this hint


part No: ATPFF12864WP67
and another in

Display used is the ATPFF12864WP67 from ArrowTech. Maybe you can find a compatible device.
However nothing else that could help me to test the LCD board.

Any ideas?

Hello Achim57 & streetman_chris,

If after replacing CD4050 and / or CPU the problem is still not solved.
Possible problem with the display. In this case it will be best to return the product to the store where purchased for RMA REQUEST.

Best regards,
Velleman Support