Code lock K6400 not working after assembling


I recently put together the parts of the code lock K6400 Kit with highest precision (in about 10 hours) to avoid mistakes.

When finished I supplied the modul with 9 V (later 10 V) DC from a stabilized source (labor device) over the blue connectors V and GND in the right polaritiy.

Result: It does not switch the relais after entering the 4-digit-Code in 5 seconds. Nothing happens. Like dead. Can’t hear anything from the relais. No LED function also.

It is absolutely shure, that the voltage reaches the blue connecton on the platine. So, the problem should lay on the board(s).

I have chosen the following Jumpers on the Master module:

  • No Jumper at the point “J”
  • No Jumper at the point “J1”
  • Jumper at the point “NO”

I have chosen the following Jumpers at the keyboard module:

  • Points A, B, C, D have been bridged to one of the SW (Mini-Switches) each. (4 SW)
  • All not used SW have been bridged with “N” (5 SW)
  • Remark: one Switch has been left over (Nr. 10). Don’t know why there is one left? Don’t need it.

The connection between the two boards are done with uninsulated wires from the tape (with the resistors)

I have made some pictures. How to upload them?

Do you have any sugestion to solve the problem?

Thank you for assistance in advance.

Sorry, you cannot upload a picture, you will have to link to them via a free picture base.
Please note that 10VDC is not enough to energize the relay in a reliable way, you definately need 12VDC.
What code did you choose?

Looking at the the assembly manual.
You need to mount the jumper marked “J”
The place marked “J1” is optional.

Thanks for the hint, wrong way, with the jumper at “J”. I didn’t understand, what this jumper exactly will do. So I thought better to let it out of the board. I go down and will make a connection at “J”. Then we’ll see.

Vel417: In the manual they talk about 9 Volt until 15 Volt. So it should work with 9. Otherwise it should be mentioned in the manual. I bought the modul just because I wanted to run it with a 9 Volts block battery.

Also, in the manual there is on the “schematic diagram (Control section)” no IC involved. Is that a mistake in the manual? Don’t understand the drawing.

When I’m back and the modul still is not working I try to upload 4-5 pictures. But this takes time for me, cause I’m not experienced with that.


It is not a good idea to run this kit from a 9V battery.
The relay is a 12V relay. Specs say 9-15V. With 9V coming from a power supply, the relay will most likely work fine.
However, the voltage from a 9V battery drops quite fast. We cannot guarantee that the relay will work in a reliable fashion on say 8.5V…

The IC is present on the diagram, but not in the way you expect it. ES1 to ES4 is in fact the IC. It is drawn this way for clarity.
Pleae Google for the IC datasheet if you want to see the pinout.


It works. It was the “J” Jumper. It must be solded in. Thank you very much, Wrong Way.

May I suggest to the Velleman company to make that point clearer in the manual? It would pay off by having less questions from users.

Vel417: I tried it with a 9 Volt Block Battery (a pretty old, but never used one) and it worked. But exactly at 9 Volt (stabilised source) it refuses to. A brandnew 9 V Block has about 9,5 V in the beginning. So it should work pretty descend for a while. It’s not a life saving application in my case. Just to open a door without a key from time to time.

The IC issue is solved also. Same suggestion like above: please put this info into the manual. It’s better.

And a last issue that also belongs into the manual: with the 22microF condensator the opening sequence of the relais lasts about 6 seconds. This is an important information for a customer to calculate with.

Thank you all for your commitment.