Broadband hub problem

When I run my K8200, my broadband hub loses connection. I have tried fitting a ferrite core on the mains supply lead, and also screening the power supply, but neither has had any effect. Has anyone else noticed a similar problem? Any suggestions?

Hi ghar,

when does the problem occur? When the printer is powered, or when it is actually running?


That was a quick response
I notice it after the printer has been running for a minute or so.

Hi ghar,

not quite clear what could be the cause of this.

I checked my setup, and I can measure em emissions both from the power supply and from the motors (or rather their wiring). But it’s rather “low” frequency, compared to the usual wireless comm frequencies.

The power supply produces comb-shaped spectra (as usual for switching-mode supplies), but the amplitude decreases rapidly with increasing frequency (also as usual), and there are no components above 300 MHz that I can measure. Below that frequency, the emissions depend greatly on the load, i.e. you can see from the spectrum whether the motors or one of the heaters is on.
The motors are PWM-regulated, so it’s no surprise that they generate high frequencies, too. However, the highest I can see in the analyzer is about 400 MHz, and it’s still much lower than the signals on the standard mobile phone bands (here: 900, 1800, and 2100 MHz). Thus, it should not cause any interference at those frequencies. If on the other hand your hub is somehow sensitive to this specific frequency, it is possible that this is the cause of trouble.

Perhaps you can isolate the cause of the error a bit. When the printer is on, you can enable the motors by moving them with the manual commands. Homing works, too. If the motors are enabled, you’ll note that the axes can hardly be moved by hand. Not the Z motor though - it’s set in the firmware to be automatically switched off if not in use. If your hub is still working in this state, it points to the power supply. If it’s not, it can be both, since in this case both the supply and the motors are active. Disable the motors with the button in Manual Control, and switch on both heatbed and extruder heater. This will set the power supply to about 70% load. Recheck the hub. If it works: motors, if it doesn’t: power supply.

What you can do (in case of the motors): check the cables for open loops. The motor cables are two pairs, each driving one coil in the motor. Those wire pairs should be kept as close to each other as possible over the full length. If there is a loop, it’s probably at the end, since the ribbon cable already takes pretty good care of the parallel routing of the wires for the most part.

You can also try different stepper motor drivers. E.g. the DRV8825 use a different PWM frequency for driving the motors. However, I cannot promise that it will help, it could just as well do nothing or make the error worse. You can only tell by trying. Also note that the above mentioned drivers have x32 microstepping.

If it’s the power supply and not the motors, the solution would of course be to use a different power supply. Perhaps you have a suitable supply at hand for testing or know someone to borrow it from? Should be capable of 15 V and at least 100 W, you’ll also find those values on the label.


hi kuraasu,

Thank you for your comment.
I have done the tests you suggest:
The motors do not trigger the problem.
The heaters cause my hub to lose broadband connection after between 10 and 30 seconds, so presumably it is the power supply causing it.
I don’t have access to a 15 volt 100w power supply, only a 12 volt one.

Do you think there is any point in fitting a mains input filter to the power supply?


Hi ghar,

you can try, but probably the filter won’t help, since it’s the supply itself that “radiates” and not the input cable. Encasing it in some sort of Faraday cage is also not really an option, because the supply needs free air flow (or rather convection) for cooling.

A 12 V supply can be used to power the printer, the controller board and motors have regulators that will adapt. However, the heating power in both the extruder and the heatbed will be reduced to 66%. The power requirement is thus a bit lower, nevertheless a sufficiently large supply is still necessary of course.

For PLA there are several adhesion promoters (lots of info in the Issues section about that topic). Most users still print on a warm printbed, but with good adhesion, PLA can also be printed on a “cold” (room temperature) bed. If you can find a suitable combination of parameters for your filament, you could leave the heatbed off most of the time. However, the extruder still needs to be heated, so this would still solve only half of the problem.


hi kuraasu,

Thank you for your help.
I followed up on Faraday Cage and found the problem stopped when I placed the powere supply in an open top metal biscuit tin.
The power supply does not seem to overheat.
The tin is a nuisance, but, hey, it works.



Hi i have just recieved a new board as my other one broke. plugged it into to my computer the red and green lights are constantly on. but the computer does not try to install a driver after downloading the driver off of the website. i unplugged all the printer cables and just plugg in the usb but still no serial port showing up and arduino software does not show serial ports either. what does the 2 usb green and red led lights constantly being on mean? please help


If it’s just the 2 LEDs on this indicates the the board is not getting 15 volts from the power supply
You check it at the blue connector
Also check the 5 volt regulator for over heating if you are getting 15 volts.
If it is you may have a short in the wiring.